Renault Clio I - Engines - Timing belt failure help needed - Page 3 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 27th January 2008
Junior Member
Join Date: Jan 2008
Posts: 7
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 1 Time in 1 Post
hello, back again, ok, got the new valves into the head with new oil seals, set the valve clearance, new head gasket set, oil , oil filter, air filter, altonater belt, oh and a timing belt, just thought get all the parts for like a service since i was doing this amount of work to the engine, didn,t do spark plugs because there was no trouble with them before the timing belt broke, so, got everything set, camshaft pully wheel lined up, crankshaft wheel lined up, put the timing belt on, lining up the marks on the the belt with the marks on the wheels, tighten it all up, everything looking good, START YOUR ENGINES, oh dear, sounded ok for about ten seconds, but just wasn't right, went for a drive, chuggy and no power and a clicking noise from the top the engine this was saturday at 5pm so we called it a day, today, sunday, i thought it had to be the timing, so back to my friends driveway, had a look, the timing belt was one tooth off on the top camshaft wheel and ok on the bottom crankshaft wheel so, set the camshaft wheel back a tooth and i now drive a sweet sounding 1997 clio,,,, and all for 100.00 which can't be bad,,,but if you want to do the work yourself you will need 3 different types of socket sets, hope this is helpful to others, i learned a bit here too, if you cannot do this type of job yourself, then i think it may cost you 700 to 1000, and my car is worth 300 heh heh, cheers, kenny.

Last edited by kennybo; 27th January 2008 at 10:57 PM. Reason: just
kennybo is offline  
Sponsored Links
post #12 of 12 (permalink) Old 28th January 2008
Platinum member
Tiggerz_SRi's Avatar
Join Date: Dec 2007
Posts: 16,417
Nominated 0 Times in 0 Posts
Nominated TOTW/F/M Award(s): 2
Thanks: 2
Thanked 12 Times in 12 Posts
Send a message via MSN to Tiggerz_SRi

Glad its back on the road!
Currently in Tiggerz_SRi's garage:
Audi a4 v6 avant, used to have bmw 525d se estate, 2001 Toyota Previa 2.4 VVTi GLS, '98 R FORD Galaxy 2.3 Ghia X a Espace III 2.2dT RXE and a Lag I 1.8RT!
Tiggerz_SRi is offline  

belt , clio , engines , failure , needed , renault , timing

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome