Renault Clio II - Engines - Non starter due to poor earth - Solved - Page 6 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #26 of 28 (permalink) Old 7th July 2007 Thread Starter
Join Date: Jun 2007
Posts: 34
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Hi Paul,

Hey hey, its runnig perfectly now!!!

Put a new earth strap on, and stripped the throttle body down and gave the parts a good cleaning in some petrol, and hey presto. It is probably my imagination but I reckon the engine is running more smoothly now.

Thanks for your help.
Currently in boeingpete's garage:
Renault Safrane
boeingpete is offline  
Sponsored Links
post #27 of 28 (permalink) Old 7th July 2007
Junior Member
Donnyshep's Avatar
Join Date: Jul 2007
Posts: 8
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to Donnyshep
Yes i said exactly the same mate, probably due to cleaning off years of oil and dirt from the throttle body .
But yes definatley an improvement,
Well thats the end to the mistery
Currently in Donnyshep's garage:
Phase 2 Megane Coupé Dynamique +
Donnyshep is offline  
post #28 of 28 (permalink) Old 7th July 2007
Technical Supremo

Join Date: Feb 2007
Posts: 42,940
Nominated 16 Times in 67 Posts
Nominated TOTW/F/M Award(s): 28
Thanks: 372
Thanked 5,201 Times in 4,712 Posts
Many thanks to Donny and Pete for their determination and success and of course locating the engine earth strap. I sure this info., will be very useful to others in the future. Apart from starting problems bad engine earths are notorious for other problems as the engine electrics depend on having a good clean earth point. In the past I have seen cars suffering from burnt out throttle cables as in some cases the engine will try to earth any source it can. Electricity is a lazy brute and will always take the shortest route even along other positive cables when a good earth is not present.
Well done again and many thanks for the updates.
Currently in madnoel10's garage:
Honda Civic 1.4l
madnoel10 is offline  

clio , earth , engines , poor , renault , solved , starter

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome