Renault - Clio - Running Problem *fixed* - Page 2 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #6 of 7 (permalink) Old 15th August 2007
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
thanks for the update
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
Sponsored Links
post #7 of 7 (permalink) Old 19th August 2007
straitwurly's Avatar
Join Date: May 2006
Posts: 38
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
loss of power..

I had a similar problem when I got mine, I think. When driving, suddenly all the dials and lights would go off on the instrument panel for a second, reset my journey mileage, then go back up. I had it checked 5 times by the dealership who told me there was nothing wrong, then a month after my warranty ran out I took it back to get them to check all the electrics and - would you believe it? - they found a fault. They had to replace my electronics cluster, and quoted me about 700. I refused to pay because I had been in so many times, and they did eventually do it for free..

Don't know if this is the same problem as yours, but it might be an idea to check.

straitwurly is offline  

clio , fixed , problem , renault , running

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome