Renault Clio II - Electronics - TDC sensor - Page 6 - Renault Forums :: Independent Renault forum

LinkBack Thread Tools Display Modes
post #26 of 72 (permalink) Old 29th August 2006
Join Date: Aug 2006
Posts: 36
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to chalky2k
recently changed the TDC sensor on my cilo.. everything was well for a few days. then started back up. now my car stalls when driving and even refuses to start for a while and the organe electrical fault light flashes and comes on. i notice this problem today on my drive to work. so although it sounds like a tdc sensor problem it may not be.

I went out and brought the dam TDC sensors and fitted it. NOT THE PROBLEM.

i drive a 1.2 16v 2001 Clio. if anyone knows of my problem. please help.

chalky2k is offline  
Sponsored Links
post #27 of 72 (permalink) Old 30th June 2007
Junior Member
summercamp's Avatar
Join Date: Jun 2007
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi everyone!

with my limited knowledge of engines - would this TDC sensor apply to diesels? I guess they have pistons which also have to get to TDC before the glow plug heats up???

my 2001 Clio diesel has starting problems - I thought it was the immobiliser but the engine turns over and I guess the immobiliser wouldn't let the engine turn over??

or would it?

since it's a newer model the problem with the leak doesn't apply

currently recharging the battery after it went flat - anything special I need to do when I replace the battery? Like reset the immobiliser as mentioned on another thread?

also someone mentioned a fuse - what was that about?

due to the popularity of this site it takes ages to find the right info (I've been looking for various bits of info for about 3 hours now lol)

anyway - keep up the good work
Currently in summercamp's garage:
always had old cars - I love classic sports cars - am a dab hand with fixing them old machines - currently have my baby - Clio mk 2 diesel
summercamp is offline  
post #28 of 72 (permalink) Old 6th July 2007
Join Date: Jul 2007
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
TDC sensor

Heartfelt thanks to the person that showed picures of the TDC , I had found out from the forum that this was probably the cause of the non starting of my Clio RXT, now severe, but not knowing what the thing looked like I dreaded trying to explain this to a French mechanic (I live in Burgundy) now I can show him and hope that he can fix it before my date with the MOT inspector. Thank goodness for the internet and forums like yours
Currently in 21854's garage:
Renault Clio RXT
21854 is offline  
post #29 of 72 (permalink) Old 7th July 2007
Let's be carefull out there
chris m's Avatar
Join Date: Jan 2006
Posts: 19,344
Nominated 1 Time in 1 Post
Nominated TOTW/F/M Award(s): 3
Thanks: 3
Thanked 32 Times in 32 Posts
Send a message via MSN to chris m
Welcome to the forum, Sue. Glad we could help.
Currently in chris m's garage:
2000 Scenic 2.0 16v Monaco, BMW 3 Series, Pug 206
chris m is offline  
post #30 of 72 (permalink) Old 3rd August 2007
Junior Member
Join Date: Aug 2007
Posts: 1
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
TDC problem

Hi all, I'm new to this forum as of a couple of hours ago, I googled 'clio starting problems' in despair after many failed attempts on getting my car repaired.

Basically I've got a 98 ClioII 1149 RN. In the last couple of weeks it has only started intermittently, in that when it didn't start the engine turned over without firing. Obviously when I asked a mechanic to look at it it started immediately every time in a 'herbie-esque fashion' making me look like a fool.

Well cutting to the chase, within an hour or so of reading about the TDC and its problems and looking at the photos of the Laguna TDC , I have taken mine out cleaned off all the gunk and replaced it only to find the car fired immediately and continues to, fingers crossed.

Previously this morning the battery was almost flat following numerous attempts to get it going.

I'd just like to thank everyone who has contributed to the information in this area, You've saved me a lot of time and money and are certainly a lot more knowledgeable than the guys I've approached re: the problem. Viva le forum
lynsandtone is offline  

clio , electronics , renault , sensor , tdc

Quick Reply

Register Now

In order to be able to post messages on the Renault Forums :: Independent Renault forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

  LinkBacks (?)
LinkBack to this Thread:
Posted By For Type Date This thread Refback 12th March 2007 11:55 AM

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome