Renault Forums :: Independent Renault forum - View Single Post - Renault Megane - Radio And Time Display Bulb Replacement

View Single Post
post #33 of (permalink) Old 3rd December 2012
Junior Member
Join Date: Jun 2012
Posts: 15
Nominated 2 Times in 3 Posts
TOTW/F/M Award(s): 0
Thanks: 1
Thanked 18 Times in 9 Posts
Re: Renault Megane - Radio And Time Display Bulb Replacement

I think you've got the combined radio/clock display then - I've got the one with the two separate displays - the clock has that normal black lamp, and the radio display is a small Philips made box with these two yellow lamps in it. And yes, the bulb was pulled from the holder. Its 4.8mm in diameter like the bulbs in the black holders, just shorter without that glass plug socket. Anyway I'll probably just fit in the standard plug bulbs - they'll stick out a little further but it shouldn't matter much, there's plenty of room where they plug into.

The bigger picture:
This car is a full time job (honestly, I'm a student, but at the moment what I'm doing is pretty much this: 6 days a week working on the car, 1 day studying , and that's been going on for over 2 months now). The reason the lamp went was the radio LCD acting weird - looked like some humidity got onto the display connector. So I removed the display and cleaned it, put it back together, it was fine again but then one of the two lamps stayed dark. Now another broken thing - a few days later, I started up the engine and turned up the heater fan on level 1. A few seconds later it went to full power and stayed that way, no matter on which level I set it. Don't worry though I got that one figured out and its rather easy and cheap to fix . I just hope there's an end in sight because the coolant is slightly leaking from the water pump, the cam belt should be changed, and if I'm really lucky the head gasket needs replacing too because the coolant system was full of goo (probably not flushed in 14 years), the oil rusty brown, and almost 1 liter of coolant disappeared in 2 months with the car not being moved - either it went dripping out the water pump, or into the engine oil , the latter being more likely with all the white smoke I'm now getting out of the exhaust ). Anyway, I hope I can postpone those complicated works until spring when its nice and warm outside. Right now I'm fixing the small things like door locks that wont unlock with the central locking, broken plastic bits, broken fog lights (the lenses fell off when I fiddled with them ), water entry into rear lights, squeaking noises here and there and lots of other stuff... But if the engine doesn't make it till spring, too bad

I know it should be the other way around - fix the important stuff first and the minor things later, but the minor things are just more fun and rewarding to fix
Currently in forlix's garage:
Megane 1.6i (BA0L, 55 kW, A/C, 1998/03)
forlix is offline  
For the best viewing experience please update your browser to Google Chrome