Renault Forums :: Independent Renault forum - View Single Post - 2005 Clio ABS fault

View Single Post
post #1 of (permalink) Old 9th March 2013 Thread Starter
Junior Member
Join Date: Mar 2013
Posts: 11
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 2 Times in 2 Posts
2005 Clio ABS fault

Firstly, Hi all. This is my first post.

I just purchased a 1.2 16V 2005 Clio. Unfortunately the car had tape over the air bag, serv and abs warning lights and they are all on. Cant take it back for many reason (long story) so need to get it working. It's for my son to start learning to drive.

Firstly, the ABS light does not go off at all. Would this suggest a sensor fault?

An indipendant dealer has been looking at it for me and has read the codes. Nothing about ABS in the codes at all but load of air bag issues.

The reluctors seem fine and we are getting a signal from the sensors. We changed the abs pump and the fault went away for a bit. I then got them to fit new front disks and pads and still fine. But the ABS light came back on after a few minuites driving and now stays on.

Any suggestions would be appreciated as we are a bit stuck now. Should the ABS light go off after starting the car or will it need to be reset by the dealer before it clears?

Thanks very much.

Currently in trenery's garage:
2005 Clio 1.2 16v
trenery is offline  
  5 Lastest Threads by trenery
Thread Forum Last Poster Replies Views Last Post
Clio 1.2 2005 airbag warning light Electronics Ralph 8 10210 25th March 2013 11:05 AM
2005 Clio ABS fault Brakes/Hubs Ralph 16 5256 9th March 2013 04:35 PM
For the best viewing experience please update your browser to Google Chrome