Renault Forums :: Independent Renault forum - View Single Post - Renault Laguna 2 - 1.9dCi No Turbo Boost/Limp Mode*FIXED*

View Single Post
post #28 of (permalink) Old 25th July 2013
ReanaultInFrance's Avatar
Join Date: Oct 2008
Posts: 88
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 18
Thanked 2 Times in 2 Posts
Re: 2001 Renault Laguna II diesel "Yellow Glow Plug and Electronic Fault warning ligh

Originally Posted by Grumpy in Somerton View Post
Over the past several years my daughters have bought a 1998 Renault Clio and a 2004 Renault Meganne 1.9 DCI. Both of these vehicles have been faultless in performance; maintenance has been the usual MOT and schedule maintenance. For that reason, I bought a used Renault Laguna 1.9 DCI from a garage in Somerset and during the first three weeks I’ve had the car, it has performed perfectly, however, week four has not gone without notice; yesterday, the yellow “Glow Plug /Electronic Fault” warning light began showing on the dash constantly…the performance curve falls off sharply…and the engine seems to go into protection mode; the turbo shuts down and the car creeps along at 40 MPH. Took the vehicle into the garage yesterday, they put the vehicle on a diagnostic…said they could not find any problem…drove down the road for ten minutes and the light returned. So long as the vehicle is cold the light does not come on… once the engine comes up to running temperature the light reappears and stays on constantly and the engine sounds like a diesel tractor. Really disappointed in Renault right now…this seems to be common matter that should have been a re-call by Renault…but hey, Renault a French company and I am sure there is some sort of Union rule that forbids company employees form doing re-call work. Any advice on how to go forward would really be a great help. Looks like I might also need to educate the local garage on this “Common” problem…Renault, I really am disappointed with your inferior customer service and ridiculous hourly maintenance cost in England…
Ripped off in Somerset
If it's any consolation, Renault dealers in France are equally as bad. My Laguna runs perfectly from cold, but as soon as the temperature gauge hits the normal operating temperature, on comes the 'check injection' light and she goes into limp mode. We are at the end of our tether with this on-going fault. I am going to start a new thread as I have taken photos and don't want to hi-jack your thread.
Currently in ReanaultInFrance's garage:
2006 Renault Laguna 2 1.9 Dci Expression
ReanaultInFrance is offline  
For the best viewing experience please update your browser to Google Chrome