Renault Forums :: Independent Renault forum - View Single Post - sat nav

Thread: sat nav
View Single Post
post #1 of (permalink) Old 8th November 2006 Thread Starter
Junior Member
Join Date: Nov 2006
Posts: 3
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
sat nav

Hi I am a new member but I seem to be having the same problems as everyone else. 2003 Renault laguna 2 1.9dci hatch back. My icons on the screen tell me I am not recieving a signal from the sattalites (shows red). I have been to renault and they told me that the reciever was OK but could not tell me what was wrong unless they fitted new parts and charged me for the parts weather it fixed it or not. SAME OLD STORY. When I investigated the problem I found the chip in the external reciever (on roof) was full of condensation. This can be no good for the chip.
Please if any one can help I would like to know where the connector is between the external reciever and the cable to the front of the car.
Even though renault checked this out I am going to fit a new one and then I could try all the other ideas on this site.
Any one know a cheap supplier of parts or a very good engineer that would be able to fix it
Currently in flow's garage:
2003renault laguna2 1.9dci initiale
flow is offline  
  5 Lastest Threads by flow
Thread Forum Last Poster Replies Views Last Post
sat nav Electronics rhuiridh 4 937 8th November 2006 11:21 AM
For the best viewing experience please update your browser to Google Chrome