Renault Forums :: Independent Renault forum - View Single Post - Megane 16 8v Revving & Stalling!! Help!!

View Single Post
post #1 of (permalink) Old 11th October 2005 Thread Starter
Junior Member
Join Date: Oct 2005
Posts: 12
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to MeganeRT16
Exclamation Megane 16 8v Revving & Stalling!! Help!!

I have a megane hatch 16 8v and i have been having this problem for while now and i cant seem to find what is causing it.

When i start the car its fine, but as soon as it heats up, either the revs get stuck at somethin like 1500 rpm (when it usually idles on around 800rpm) or else as soon as i dip the clutch the car either stalls or knocks.

I tried removing the TB and cleaned it throughout, changed the gasket and also cleaned the map sensor . but all this seemed to actually make things worse!!

Can anyone give me some advice on what this could be?? My car is becoming undrivable now and its a pity cause its in very good condition otherwise...

MeganeRT16 is offline  
  5 Lastest Threads by MeganeRT16
Thread Forum Last Poster Replies Views Last Post
Megane 16 8v Revving & Stalling!! Help!! Electronics MeganeRT16 9 2192 11th October 2005 08:15 AM
Water Leak Megane 5dr!! pls help!! Interiors Bob925 11 3273 7th October 2005 08:50 AM
Stalling & Bad Running Megane 16 8v Welcome to RenaultForums RTE 2 1151 5th October 2005 01:41 PM
For the best viewing experience please update your browser to Google Chrome