Renault Forums :: Independent Renault forum - View Single Post - Renault Clio 2003 - Engines - Loss of power and Warning Light

View Single Post
post #286 of (permalink) Old 5th August 2013
Diamond member
MissClioSportS's Avatar
Join Date: May 2012
Posts: 103
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 11
Thanked 7 Times in 7 Posts
Re: Renault Clio 2003 - Engines - Loss of power and Warning Light

Originally Posted by sixteen_valve_vanessa View Post
Hello - first post. I've had a trawl through the forums and found similar questions but can't find one that matches my own problem.

Basically what happens is that I am driving along and all of a sudden my clio (03 Clio Expression 1.2 16v) dramatically loses power and acceleration. When this happens the electronic fault warning light comes on on my dashboard. (The one with a jagged line and a 'squiggle' beneath it!)Because my maximum speed drops to about 30 mph I have to limp to a layby or the next set of traffic lights and turn the car off and on again. This always seems to clear the problem... until the next time it occurs.

I took it to a garage who hooked my car up to a system which is (supposedly) able to diagnose the fault. They said that it was a problem either with the throttle potentiometer or another little switch. So I spent 120 quid having this diagnosis done and these two components changed. Guess what? It still happens!

I have had the car for a year, it has 63k miles on the clock and this fault has been occurring intemittently for about 4 months. Unfortunately it has been happening more and more recently such that it happens pretty much every journey I make now.

Its bloody annoying and actually pretty dangerous as it seems to happen without warning. Any advice gratefully received!

PS My car is blue if that makes a difference.
I had the same problem when I first bought my clio a year and a half back. It happened about 4 times but then the problem literally vanished. Ive not had a problem since. I put it down to it having sat on the previous owner's drive for a year without moving.

I hope you find out the cause!
Currently in MissClioSportS's garage:
2013 Renualt Clio Dynamique MediaNav TCE 90
MissClioSportS is offline  
For the best viewing experience please update your browser to Google Chrome