Renault Clio 2 - Poor Running/Dash Warning - Renault Forums :: Independent Renault forum

Go Back   Renault Forums :: Independent Renault forum » Problem Solving » Ask the Experts » Engines

Notices

Engines Engines and other oily matters

RenaultForums
... Quick links
... Forum list
... Your dashboard
... Search the forums
... List new posts
... List today's posts
... List 0 reply posts
... Live post list (iSpy)
... Most viewed threads
... Special offers
... Members
... Member list
... Member map
... Member's gallery
... Who is online?
... Social groups
... Forum leaders
... Information
... FAQ index
... Garage list
...   Map version
... Glossary
... View our rules
...   Advertising
...   Privacy policy
... Contact us
... Feedback
... Fun stuff
... Arcade games
... Chat room
... Folding@Home
... Data
... Who drives what?
... Who supports who?



Use the drop-down below to display RenaultForums in the language of your choice.

Renault Clio 2 - Poor Running/Dash Warning

Engines


Reply
 
Thread Tools Search this Thread Display Modes
Old 18th November 2009   #1
Pea
Pea is
has no status.
Member
 
Join Date: Feb 2008
Posts: 60
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 26
Thanked 2 Times in 2 Posts
Renault Clio 2 - Poor Running/Dash Warning

Looks like my car is buggered...

It wouldn't start first time, but did second time. When it did, it had the below light on, and I've no idea what it means - any ideas? I mean the one in the middle below the petrol light.



The engine then started revving itself slightly for no apparent reason when I had the clutch down. Then when I tried driving off, the engine wouldn't go above about 2000 revs no matter how far down I pressed the accelerator, or what gear I was in.

Any ideas what might be wrong?

Cheers

Pete
Currently in Pea's garage:
2001 Clio II Authentique 1.2, 2006 Scenic II 1.6

Last edited by Pea; 18th November 2009 at 01:33 PM.
Pea is offline   Reply With Quote

5 Lastest Threads by Pea
Thread Forum Last Poster Replies Views Last Post
2006 Scenic Battery Warning Electronics BLACK ESPACE 8 427 23rd March 2014 11:05 AM
Scenic II lights issue - bulbs fine, multiple... Electronics lancs dave 3 411 22nd November 2013 02:45 PM
Clio clutch pedal has no resistance Transmissions Lagdti 18 2378 2nd February 2013 02:43 PM
Does the Clio have body paint drain plugs? Bodywork Pea 15 1726 26th December 2012 07:33 PM
"Random/Multiple cylinder misfire... Engines mickeybo 11 2663 11th December 2012 09:38 PM

Sponsored Links
Advertisement
 
Old 18th November 2009   #2
Lion86
Lion86 is
has no status.
Junior Member
 
Join Date: Nov 2009
Posts: 16
Nominated 1 Time in 1 Post
TOTW/F/M Award(s): 0
Thanks: 2
Thanked 1 Time in 1 Post
Just from experience, it sounds like your cam sensor may be shot, I've done a few clio's with the same symptoms, but i've not really seen a warning light like that come on before.

Is there a local garage who will test it?
Most have the fault code readers nowadays and charge around £20, always worth having done with anything electrical.
Lion86 is offline   Reply With Quote
Old 18th November 2009   #3
qwakers
qwakers is
riding a r6 in the warm and dry, and using the company van for the rest.
Platinum member
 
qwakers's Avatar
 
Join Date: Oct 2009
Posts: 1,075
Nominated 2 Times in 2 Posts
Nominated TOTW/F/M Award(s): 1
Thanks: 2
Thanked 79 Times in 74 Posts
Send a message via AIM to qwakers
where in the country are you? thee is quite a few peeps about that nhave diagnostics reader, me included...
Currently in qwakers's garage:
Lag II sold ;-( Yamaha R6 04 black/Grey RangeRover 4.0v8 towcar and bobtailed discovery for offroading.
qwakers is offline   Reply With Quote
Old 19th November 2009   #4
Pea
Pea is
has no status.
Member
Threadstarter
 
Join Date: Feb 2008
Posts: 60
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 26
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by qwakers View Post
where in the country are you? thee is quite a few peeps about that nhave diagnostics reader, me included...
I'm in Guildford, Surrey, but for obvious reasons can't get much further than that!
Currently in Pea's garage:
2001 Clio II Authentique 1.2, 2006 Scenic II 1.6
Pea is offline   Reply With Quote
Old 28th November 2009   #5
Pea
Pea is
has no status.
Member
Threadstarter
 
Join Date: Feb 2008
Posts: 60
Nominated 0 Times in 0 Posts
TOTW/F/M Award(s): 0
Thanks: 26
Thanked 2 Times in 2 Posts
Re: Renault Clio 2 - Poor Running/Dash Warning

Do I need to take it to a Renualt garage to get a diagnostic reading, or might a local independent garage have the appropriate kit?
Currently in Pea's garage:
2001 Clio II Authentique 1.2, 2006 Scenic II 1.6
Pea is offline   Reply With Quote
Reply

Tags
clio, clio or what, dashboard, light, poor, renault, running or dash, warning, wrong

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © 2005-2009 RenaultForums
 
Inactive Reminders By Mished.co.uk and FTP-Anime.com