Independent Renault Forums banner

Search results

1-17 of 17 Results
  1. 2002 megane

    Engines
    Looks like your air conditioning pipe broke apart. It won't affect your car engine only the air conditioning system.
  2. intermittent starting problem scenic 1.5 dci 2005

    Engines
    Mine had a similar problem, to solve the issue I had to disconnect the negative cable first, then the positive cable. At the top of the positive cable are three fuses (image below), you must remove the nuts, sand the connections until it is free of corrosion, assembly everything together and...
  3. Difficulty to read oil level

    Engines
    Hi Phil, Thanks for your reply. Yeah, my street has a slight slope... I thought that wouldn't interfere but I was wrong. The car was sitting for about 10 minutes and I thought that would be enough too, so I was doubly wrong lol The tricky thing is that my neighborhood is all uneven, full of...
  4. Difficulty to read oil level

    Engines
    Hello folks, First of all, thanks for your time and dedication to the forum, it's priceless. Well, I'm having a weird situation with the oil level of my car (Megane 2 1.5dCI engine K9K). I pull out the dipstick, clean it up and put it back, pull out again to see the oil level, as the normal...
  5. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    I followed your advice and cleaned that pipe and the EGR again, they were all oily again, probably because the oil was returning from the turbo due the clogged return pipe. With that new cleaning and the replacement of the turbo's return pipe I can say that the smoke is gone. I really...
  6. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    If the feed had blocked, well that would be expensive. Can the blocked return pipe be related to the smoke? After all, if the oil can't return to the crankcase, it has to go somewhere, right? I'm attaching the photos of my engine. It's a K9K engine with 82hp. Cheers!
  7. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    There is no problem, man. O-rings fail all the time, and the pipe was blocked with dirty, things that happens. Yes, that's the name of the pipe, I didn't knew the term in English so I used something similiar haha The pipe is very similiar to the one I attached now. I will take some pictures...
  8. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    Well, I did a good hard run at Thursday and apparently the smoke was gone! So I parked the car in front of my home and I came out about 45mins later and I notice a huge pool of oil underneath the car! :( I opened the bonnet and there was oil all over the place, in the radiator, the battery, the...
  9. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    Thanks for the advice, man. I feel more relieved. I will have time available for me only on Thursday, until there I'm with work to do until the bone lol I'll give her another good hard run and share the feedback after it. Cheers!
  10. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    ours2012, I gave it a hard run but I didn't see any improvement and during the run, a message about the injectors showed up in the dashboard, it reads "Check injection" and the service light also lit. After a minute or so the warning disappeared and I continued to drive. That's bad isn't?
  11. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    I will give it a try tomorrow and I will update this thread. Thanks. Sent from my iPhone using Tapatalk
  12. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    Yes, it's starts very well no matter the weather. Sometimes it smokes at starting. Maybe the injectors are bad? I didn't notice any oil consumption yet...
  13. Megane 2 1.5dCI - smoke problem ( Solved )

    Engines
    Hello everyone, Recently I bought a cheap Megane 2 1.5dCI with 82hp and it had a huge smoke problem. Sometimes the smoke was a dense blue cloud and some times not so much. So I removed the EGR, intercooler pipe (that one that is curved), PCV valve, PCV pipes, the inlet pipes coming from the air...
  14. Rear fog light issue, fuse/relay? (Renault Megane Mk3)

    Electronics
    Hi Jake, I'm sorry, but I can't help you. Actually, I'm with a similar problem with my Megane II with the right side rear fog, the bulb it's ok (I already changed it) but there is no current at the connector. I'm too couldn't find any mention to a fuse in the manual, so I will follow your...
  15. My introduction

    Welcome to RenaultForums
    Thank you all guys! I will open a thread if I need.
  16. Renault Megane II - Electronic Fault*Fixed*

    Electronics
    Dear triumph2.5man, My Mégane is having the same problem. I will try all your tips tomorrow, I hope that will work. Only one special detail that happened to me and I didn't find it reported elsewhere is that the RPM gauge stopped working while the message is on the dash. I will update this...
  17. My introduction

    Welcome to RenaultForums
    Hello folks! My name is Wesley, I'm 24 and I live in Portugal. I bought a Renaut Mégane II a few months ago and since that I'm always looking stuff online like DIY, problems solving, nice modifications, etc... That forum really have a ton of helpfull information, thanks!
1-17 of 17 Results
Top