Independent Renault Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have recently bought a 1997 Trafic for spares or repair which has the 2165cc petrol engine with injection. It is running very rich, to the point where it can die sometimes. It seems worse on idle, but I think this is just that it can cope better at higher revs. There is no diagnostic port as I guess it is too old. I have tried changing the lambda sensor but this has made no difference. In fact running with it disconnected makes no difference either.

It seems to get worse the warmer it gets. There is thick black smoke coming from the exhaust, but not blue, so I assume not oil but just very rich fuel mix. I have tried plugging in another known-working good ECU and this made no difference.

When I went to look at it to buy, it started and ran only on 3 cylinders with the 4th cutting in and out and wouldn't rev, until the whole engine then died. I assumed it had run out of petrol so I stuck a 5l can in and it did then run on all 4 cylinders with the problem it now has. I was wondering if it could be an injector fault caused by running out of fuel, or maybe some other sensor? I don't know a lot about these engines, so if anyone knows more or has had similar experience I would be very grateful, thanks.
 

·
Premium Member
Joined
·
4,606 Posts
Cheap oil pressure gauge ............ plumb it into the fuel rail.


Ignition on engine off - want to see shoot up to around 3 Bar and stay there for many seconds after you switch off ignition .................if not you have a leaky injector/s


Mixture a huge function of coolant temp sensor - its ok?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for your reply, I don't have a pressure gauge tester, but I tried starting it again today and it now only runs on 3 cylinders - the 4th doesn't fire at all now. I also can't rev it, just like when I first saw it. I'm starting to think it might be the injectors, or at least one of them. I do have another 2.2 engine in the garage so I might just try and swap over the whole injector rail and injectors in one go.
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
42,966 Posts
Spark plugs ok here,,
Do the valve clearances need resetting,
Air filter in good condition..
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
25,871 Posts
If running on three, try the plugs first to find which one is missing.
Will try to stall when good plug disconnected, no change with dead one.

Good chance IMO this is plugs or coils... the dead one is likely to be oil/fuel soaked.
Start with these, don't focus on injectors yet.
They may be at fault but basics first.
 
1 - 5 of 5 Posts
Top