Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1 (Edited)
Hi all. I'm asking this question for a friend who has the laguna 2 2.2 dci 150. The other day we were out on our way to watch football when all of a sudden the car lost all its power as if the turbo had blown. Thing is that there is no signs of this due to

1. Can still hear the turbo
2. No visible smoke through any kind of acceleration
3. no warning lights
4. no oil anywhere
5. no funny noises

Please help. This is baffling most people we have asked about it. Funny thing is that his air con has also stopped working earlier on in the day. Could this be linked?

Thanks in advance :confused:

Also forgot to mention that we cleaned the EGR only 6 weeks ago so pretty sure thats nothing to do with it either.
 

·
Premium Member
Joined
·
1,370 Posts
the most logical reason is you have either blow a pipe off after the turbo, or there is a hole in your intercooler. have a poke round, it should be fairly obvious.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
the most logical reason is you have either blow a pipe off after the turbo, or there is a hole in your intercooler. have a poke round, it should be fairly obvious.
Ok thanks. We'll have a look in a short while as im meeting him later on. Hope your right or it's gonna get very expensive. :crazy:
 

·
Registered
Joined
·
83 Posts
Discussion Starter #5
aircon rad and intercooler are next to each other it is possible they are both holed :)
Can't see and sign of problems from the I/cooler or turbo? He put fuel in it yesterday and it improved a little. Today the car got worse again now displaying the injector fault. turbo can still be heard spinning but still no power when it kicks in?
 

·
Registered
Joined
·
83 Posts
Discussion Starter #6
Update*

Car feels in a fashion like its in limp mode although the dash hasn't said so? Still no visable leaks in the intercooler or air con?
 
1 - 6 of 6 Posts
Top