Independent Renault Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi everyone,I have a problem with intermittant poor starting and/or stalling ,worse when cold.Car otherwise runs very well.I fitted a new EGR valve recently that smoothed out the general running of the engine but did nothing for the stalling problem.Any advice appreciated.
 

·
Premium Member
Joined
·
499 Posts
how many miles has it done?

check glow plugs, if it is only differcult to start when cold:)
 

·
Premium Member
Joined
·
499 Posts
also listen for the relay click when the plugs are warm maybe 30 seconds after the actual light goes out.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Cheers Espaced? Would it be glow plugs if the engine's already running but stalls at first corner, and then restarts instantly?
 

·
Premium Member
Joined
·
499 Posts
possible:confused: does it run ok after a few minutes of driving?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Hi espaced,today it started and ran perfectly on two trips of 5 miles and then messed about when restarting when still warm!!!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
2.2DCI Stalling

Looks like I've now solved this problem with a new engine speed sensor.Just cleaning the old one sorted it but for £23 I thought I'd spoil the old girl.Thanks to anyone who got involved.
 

·
Premium Member
Joined
·
499 Posts
can you get a picture?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Hello espaced,Can't really take a picture of the new one as it's behind the undertray.It's the L shaped sensor retained by a spring clip that looks at the flywheel,just turn and pull to remove it.
 
1 - 10 of 10 Posts
Top