Independent Renault Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
hi i have an espace 2.2td 1999, the car takes about a minute to fire up there is smoke from the back of the car like grey to white or light black, took the car on a short run, still smoking and it has no power, very slow can you please help been working on this car for 3weeks HELP HELP, thanks
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Your pump timming has to be wrong still does it knock when reving or is it just slow to pick up ?
on tick over it will rev a little sluggish at first. when driving no power, when the engine is ticking over its quiet, on driving its loud cheers alan
 

·
Premium Member
Joined
·
2,027 Posts
should have just sent it to me lol

Sounds like you need to get another look at the belt i know its a pain but the pump is so easy to get wrong i done it a few weeks ago on 1 thought i could just clip it with crock clips but it still managed to move !!

Spent longer trying to sort it than i did doing the belt again once done ran fine first turn.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
should have just sent it to me lol

Sounds like you need to get another look at the belt i know its a pain but the pump is so easy to get wrong i done it a few weeks ago on 1 thought i could just clip it with crock clips but it still managed to move !!

Spent longer trying to sort it than i did doing the belt again once done ran fine first turn.
thanks will look again tomoz the pump timing looks as if it is at 3 o`clock cheers alan correct me if im wrong
 
1 - 7 of 7 Posts
Top