Independent Renault Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi Everybody,

First time I start my van in the morning it takes a couple of attempts. My glow plug/ Engine Management light stays on all the time. Sometimes while driving the Service light and air bag light come on together and go off. Today the red engine light came on and went off. and the reverse light doesn't work its not the bulb or the bulb holder.
I'v not had the van for long bought it private it was okay when I viewed it and when I picked it up it had the above problems plus the radio was needing the code but I have been to Renault and got that.

Anyone got any ideas whats at the bottom of the problems.
 
D

·
Guest
Joined
·
0 Posts
Hi and welcome.

The glow plug light could well be water in the fuel filter. Some of them use the same light on the dash, so probably worth changing the filter.
As for the reverse light, probably the reverse light switch on the gearbox (somewhere on the bottom or side i'd say but not sure)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi and welcome.

The glow plug light could well be water in the fuel filter. Some of them use the same light on the dash, so probably worth changing the filter.
As for the reverse light, probably the reverse light switch on the gearbox (somewhere on the bottom or side i'd say but not sure)
Hi and Thanks, I forgot to mention that I changed the filter a couple of weeks ago I thought the same thing.
 
1 - 3 of 3 Posts
Top