Independent Renault Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi everyone,
Great forum by the way found some useful stuff on here.
I'm currently in the process of upgrading some of the electrical equipment in a Clio 182.
I'm attempting to fit the climate control and auto lights/wipers.

I have the advantage of having another car that already has all these items fitted for my own reference.
I know so far I need a different wiring loom for the dashboard as well as all of the control units and sensors.
It is my understanding that I will need the higher specification UCH in order to run these items. The car currently has an 'N2' UCH, but the higher spec car I have has an 'N3' UCH.

As far as I'm aware the UCH is paired to both the ECU and the immobiliser transponder, which in turn is paired with the chip in the key.

So it seems I'm either looking at buying a new UCH of the higher specification and having it coded by Renault (if that's possible?), or buying a second hand one along with the ECU, transponder and key to match.

Where is the mileage stored on these vehicles? I just wonder if I was to get a secondhand UCH & ECU whether the car would take on the mileage of the car they came from and I would have to get it corrected? Or whether it is stored in the instrument panel?

If anyone could shed any light on this project and help me out it would be much appreciated!

Thanks,
Jack
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
Just to update the thread.

I have fitted the dash loom and engine bay loom from a vehicle with climate control, fitted the climate control which all works fine.
Unfortunately the lights are switched differently, beforehand lights were switched by a relay in the indicator stalk, however the specification cars (those with climate control) use the UCH to switch the power to the lights. So now the lights dont work. The ABS/ESP seems a bit tempermental after the wiring loom swap too.
No fault codes, however ESP,ABS and SERV lights are all lit.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Just to update this thread for anyone else interested...

The ESP,ABS and SERV lights being illuminated was down to steering angle sensor connector plug being loose.

An 'N3' UCH was purchased brand new from local dealer and coded, the conversion works perfectly.
 
1 - 3 of 3 Posts
Top