Independent Renault Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello, I have checked quite a few posts here but still cannot solve my issues.
I have a 2006 megan 2, 5 door petrol( I know it is old). First drivers side windows were broken. Mostly solved that now( temec unit and new connectors for regulator). However it has been snowing heavy here all week and I was replacing the driver door switches yesterday and I unlocked and locked the rear windows lock on that switch several times in quick succession. Now the central locking and window locks aren't working.fuse is ok and I can hear the solenoid clicking under the dash, but doors wont lock. Alarm works if I press the lock button on the remote and then open the door. Any advice please. Also does anyone have wiring schematics for this car. I have tried a few of the links but cant find the diagrams for this car.
Thanks for any advice
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
42,939 Posts
what fuse(s) have you checked?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
I have checked all the fuses in the passenger glove box. When I press the lock button on the centre console the lock light lights and the solenoid in the UCH can be heard clicking, but the door locks do not operate. Also the mirrors wont adjust from the switch now either. I have disconnected the wiring loom to all the doors and cleaned them but it made no difference. Possibly is there a fuse in the battery compartment that I cant see
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Just found a post explaining how to get to the fuses in the engine bay. Damn it sounds ridiculously difficult to access them. I will try to check them tomorrow when it is hopefully not raining(no garage to work in)Fingers crossed it's one of them
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Just found this diagram
Passenger side fuse panel....
F16 central locking fuse is good
F10 door mirror fuse is good(alarm and audio both working)
Engine Bay fuse panel......
F6 should be ok as , audio system, cigarette lighter, digital multifunction display, electric windows, hazard warning lamps all work fine
Now i'm lost again
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
42,939 Posts
Check all fuses in the under bonnet fusebox, ignore what diagrams say.
Renault are naughty like this..
YOUR first job should be to disconnect, and reconnect the battery mind.
See if that cures it first
 
  • Like
Reactions: Crzybkr

·
Registered
Joined
·
10 Posts
Discussion Starter #7
20210113_112333.jpg 20210113_112336.jpg 20210113_112349.jpg 20210113_112841.jpg well that was a nightmare. had to remove battery box to get access. only problem is that everything was ok, except a 7.5A (F6)fuse. replaced it and put it all back together. no change at all. took door loom connectors off again and inspected them. ll look good no signs of corrosion but sprayed with contact cleaner again to be sure. let them dry, reconnected them and, nothing. i'm stumped
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
View attachment 188502 View attachment 188503 View attachment 188504 View attachment 188505 well that was a nightmare. had to remove battery box to get access. only problem is that everything was ok, except a 7.5A (F6)fuse. replaced it and put it all back together. no change at all. took door loom connectors off again and inspected them. ll look good no signs of corrosion but sprayed with contact cleaner again to be sure. let them dry, reconnected them and, nothing. i'm stumped
UPDATE

so I pulled EVERYTHING apart AGAIN. Guess what I found. 10A Fuse in glove box WAS blown. How did I miss this the first, second and third time.
Well let that be a lesson to me, double and triple test fuses( I should have known better).
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
Back to my doors again. New temec fitted to drivers window motor, and the window worked great all week. Just now it started it's old carry on again. It will only go down, not up no matter which way I push the button. All other windows are good, except rear drivers door but that's because I am waiting on a new connection as the old one was fried.
Motor works fine when powered directly but only goes down on the button. Is there a wiring schematic for the driver door switches so I can test them before buying a new switch. Thanks
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
42,939 Posts
Its normally the actual plug that goes to the switch , the connectors spread open as you put the plug on.
Check the plug, and close the connectors so the two contacts inside are closer together
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
I put the meter across the two terminals that go into the motor from the regulator. They give 12v no matter which way I press the window button
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
Sorry should clarify. It shows +12v no matter which way I put the leads on to the two temic connections that lead to the motor. I'm guessing the temic is bad but I'm not sure how to test it. Only got it a few days ago.
 
1 - 13 of 13 Posts
Top