Independent Renault Forums banner
41 - 52 of 52 Posts

Registered
Joined
2 Posts
I bit of update from my renault megane fan not working, by following the thread, checking the resistor, the drain holes etc. it happens that my climate control was damage and after replacing it, everything was fine, thanks to all of you馃憦馃徏馃憦馃徏馃憦馃徏
 

Registered
Joined
1 Posts
Really helpful, my fan had also stopped working after the car was sat for 2 months waiting for accident repair. I went straight for checking the fan, removed the windscreen gutter plate, fiddled with a metal rod down into the fan, as you advised. The fan didn't move at first, then I saw the fan move slightly. I switched on the ignition and the fan fired up straight away. I think there must have bee some debris stopping the fan. All good now with no cost, just 20mins removing the gutter and general cleaning of the crap in it.馃憤thank you!
 

Registered
Renault Grand Scenic Privilege, Petrol 2009 (59)
Joined
24 Posts
I bit of update from my renault megane fan not working, by following the thread, checking the resistor, the drain holes etc. it happens that my climate control was damage and after replacing it, everything was fine, thanks to all of you馃憦馃徏馃憦馃徏馃憦馃徏
Hi, did you source and replace the climate control yourself, and it didn't need renault themselves to code it? My garage said it would need renault, but I'm loathe to believe it .
 

Registered
Joined
2 Posts
What a fantastic post this is! Had exactly the same problem, followed all the advice and fan is now running perfectly. I was preparing myself for a big garage bill and all the inconvenience that goes with a trip to the garage. I can't thank you enough!
 

Registered
Renault Grand Scenic Privilege, Petrol 2009 (59)
Joined
24 Posts
What a fantastic post this is! Had exactly the same problem, followed all the advice and fan is now running perfectly. I was preparing myself for a big garage bill and all the inconvenience that goes with a trip to the garage. I can't thank you enough!
Hi, what was your issue and how did you fix? If I may ask
 

Registered
Joined
2 Posts
I bit of update from my renault megane fan not working, by following the thread, checking the resistor, the drain holes etc. it happens that my climate control was damage and after replacing it, everything was fine, thanks to all of you馃憦馃徏馃憦馃徏馃憦馃徏
Hi guys, I have a 2010 1.6 Megane 3. I was recently caught in a heavy rainstorm and then I had the sloshing of water and a intermittend soft squeeking sound and then the blower fan fan stopped working. Reading this thread, The fuse is fine and the blower motor runs when I connect it to a 12V power supply. How can I test the resistor pack and the climate control, and how do I get to the climate control unit? Can someone assist me please? By the way, this is an excellent thread. 馃
 

Registered
Renault Grand Scenic Privilege, Petrol 2009 (59)
Joined
24 Posts
Hi guys, I have a 2010 1.6 Megane 3. I was recently caught in a heavy rainstorm and then I had the sloshing of water and a intermittend soft squeeking sound and then the blower fan fan stopped working. Reading this thread, The fuse is fine and the blower motor runs when I connect it to a 12V power supply. How can I test the resistor pack and the climate control, and how do I get to the climate control unit? Can someone assist me please? By the way, this is an excellent thread. 馃
Hi, I would suggest , if water was a factor, it would likely be the resistor, probably obvious from looks, 拢20 ebay, if it the control unit, it will be a unit electrical fail, not related to water and internal to unit 拢40 ebay.

Trouble is control unit is needed to run the resisitor to open the electric flow to the fan, so it's all interlinked

No guarantee of course

Resistor is an easy replacement, control unit is a bit more involved, as you need to unclip from door panel, centre console, gear stick and central facia.

Just have to try each fix in order of ease or probability

Try to test for voltage in from the control unit on the 2 small wires to the resistor if you can see some volts, will probably be resistor, just a guess.
 

Registered
Joined
10 Posts
Thanks for this thread. I had the issue where the motor wouldn鈥檛 spin.
It is fiddly but I used the advice in this thread to turn on the car, set to recirc and then just bump the fan blades from below. This way you dont have to actually remove anything.
 

Registered
Renault Grand Scenic Privilege, Petrol 2009 (59)
Joined
24 Posts
Thank you Mikerog25, this is helpful. Is the control unit the one where you adjust the fan speed, or is it hidden behind the panels?
Hi, sorry for delay, when i mean the control unit, yes, its the unit used to increase and decrease the temperature, and control fans and speed and AC.. Obviously some cars have these, some just have dials and switches, Mostly a silver and black, "Cars stereo" type shape in my Grand Scenic 3
 
41 - 52 of 52 Posts
Top