Independent Renault Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My alternator went so I had a new one fitted but the battery charging light is still on. Any ideas my garage has replaced the new alternator with another but still same problem. My car is a 2014 clio.
 

·
Premium Member
Joined
·
1,533 Posts
some battery terminals pos + red has fusible links in them, or in around battery fuse box
 
  • Like
Reactions: Prickleypear

·
La sola lupo
85 R11TS, 85 R9TXE, 97 Extra 1,9D, 97 Megane 2.0 RXE, 02 Clio 1,2 16V
Joined
·
1,765 Posts
Check your fuses and fusible links, check whether the alternator has a good earth on the engine,ie. metal casing of the alternator mounted on a metal part of the engine , no rubber or plastic washers or spacers between the mounting surfaces, if this is all correct have the garage connect a test light on the alternator, one side of test light earthed and the other side on the battery light terminal. if the test light goes out when the motor is running then your battery light wire may be shorting somewhere
 

·
Technical Supremo.
Scenic II, 2004, K4MW761, DPO
Joined
·
6,470 Posts
Check your fuses and fusible links, check whether the alternator has a good earth on the engine,ie. metal casing of the alternator mounted on a metal part of the engine , no rubber or plastic washers or spacers between the mounting surfaces, if this is all correct have the garage connect a test light on the alternator, one side of test light earthed and the other side on the battery light terminal. if the test light goes out when the motor is running then your battery light wire may be shorting somewhere
Sorry that is not going to work on a LIN bus alternator at all and may actually cause damage. Need a serious test bench to test an alternator properly nowadays.

Modern alternators
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
37,180 Posts
My alternator went so I had a new one fitted but the battery charging light is still on. Any ideas my garage has replaced the new alternator with another but still same problem. My car is a 2014 clio.
Was the light coming on after a few miles/minutes, or straight away
 

·
Premium Member
Clio Mk IV 1.5 dCi MediaNav S/S 2013
Joined
·
3,480 Posts
Bring back dynamo’s 😀

Why is everything in life just so complicated theses days?
 

·
Premium Member
Clio Mk IV 1.5 dCi MediaNav S/S 2013
Joined
·
3,480 Posts
Ha. I know.

Things have generally inproved, but sometimes I just think that things are just too unnecessarily complicated. Probably because manufacturers have a vested interest in trying to get you tied in to use them for service etc.

In the ‘old days’ you replaced your car because it was rotting away and that in itself generated churn, but now cars body work is so better designed and constructed, they have to find other ways to sell motors.
Just my 2c.

Sorry to hijack the thread..
 
1 - 8 of 8 Posts
Top