Independent Renault Forums banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
105 Posts
Discussion Starter #1
I wish I had smaller hands.

Installing new head unit into my '01 Laguna today and hit a few problems:

Lost power to head unit and then noticed that aircon/climate also no workee. Checked fuses by drivers door - what a nightmare, who designed that access, someone with hands the size of a two year old by the feel of it.

Established that the fuse for aircon was ok but still no power to HU or aircon/climate.

Came indoors and trawled through here to find that there is a 'secret' fuse not mentioned in the manual. It's under the ashtray. How could I have been so stupid as to not think of pulling the ashtray out and looking in there for a fuse! Sheeesh!

Trundled back to the car and had another knuckle skinning session trying to get the 'secret' fuse out. It was indeed dead. Put replacement in...... oh, that's right, it's fallen into the guts of the console beyond the reach of any mortal (unless you have an extended digit similar to the one sported by a certain lemur that uses it for digging bugs out of tree bark).

Luckily had another replacement fuse in the garage (up the lane). Put new one in and yeah.... we have power!

Now that all was working, the next task was fitting all the cabling in. Hmmm... bit like trying to force eight pounds of spaghetti through the neck of a milk bottle. Anyway, losing yet more knuckle skin took my mind off murderous thoughts. Eventually, after removing 'cubby bin' from above HU slot, I got everything sorted and tidied.

One cup of tea later and all is calm in my world and I have my new(ish) HU working nicely.

One point though. I have wired it up with the required adapter for remote stalk and display. On the dash display, it just shows 'JVC' but doesn't display radio station info or CD track info. Is this normal? It does, however, show when you're changing volume. Any advice on that would be appreciated.

I'm now off to patch up the lost skin.
 

·
Premium Member
Joined
·
209 Posts
Been through most of that pain apart from the fuse. I am afraid that is all you will get on the display - mine shows Pioneer (when it works) adaptor is being returned, so will be going through the pain barrier yet again.
 

·
Premium Member
Joined
·
644 Posts
the 'secret' fuse is a new one to me(ill be pulling out my ashtray tomorrow),whats that all about then?
 

·
Premium Member
Joined
·
644 Posts
the 'secret' fuse is a new one to me(ill be pulling out my ashtray tomorrow),whats that all about then?
 
1 - 4 of 4 Posts
Top