Independent Renault Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi,
My dash is showing check injectors on my 2004 1.5 scenic. I am aware that this is an often topic that has plauged the forums. I have found lots of posts regarding this but nothing specific to my issue.

It started a couple of days ago when the check injectors showed on the dash. The car seemed to be running fine until I came to start it in the morning when I attempted to start it there was a lot of coughing and spluttering after about the fifth go of pressing the ignition it began to start but there was alot of smoke coming from the exhaust, when driving it seems to be more noisy for the first few miles then seems fine. This happens now every morning and also if the car is at a stand still for more than a couple of hours.

Any help would be much apprciated, Im avoiding my local renault as the last few bills have been around the £500-£600 mark.

Thanks in advance
 

·
Premium Member
Joined
·
12,025 Posts
Hmm, happens when the cars cold. This would suggest something to do with the cooling system! Have you had any diagnostics run on the ECU yet to see if any codes are being thrown up? This would be the best place to start and shouldn't cost you more than £30-50!

I had an issue with a coolant temperature sensor/sender on my old V6 Laguna which caused me no end of problems. The car used to stall on me, revs would jump way up for no reason and the fact the car spoke to me and said I had an injector problem threw me right off course. £15 part fixed every single problem for me :d

My point being that just because one fault is showing it doesn't necessarily mean that's the issue. There are so many things that can cause other issues :(
 

·
Registered
Joined
·
50 Posts
Hi.
It's most likely something to do with your glow plugs. You can check the glow plugs by taking them out and connecting them to the battery, if they heat up and go red, they are fine if not get them replaced.
 
1 - 3 of 3 Posts
Top