Independent Renault Forums banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
217 Posts
Discussion Starter #1
Bought my 03 clio last night, expression model.

The steering seems a bit odd, sometimes heavy, sometimes light. So i went looking for the reservoir... no joy.

So it must be electric. If so, how do we go about servicing such a part.... im assuming there is no fluid to be used (hence the name lol). so is it just a matter of replacing the whole pump??

Also got engine management light on and a bit of a tapping/clicking/squeeking noise from the engine, isnt fast, about half a sec between squeeks. Could this be related??

All ideas appreciated!!
Thanks

Andrew
 

·
Let's be carefull out there
Joined
·
19,360 Posts
On the Mk1 with electric PS there is a resovoir but not sure where as mine is belt driven. I believe it is part of the pump unit though, which is at the front of the engine on the MK1. Try looking from below for the hydraulic pipes and try to trace them back. Also there will be switching solenoids to control the valve.
 

·
Premium Member
Joined
·
217 Posts
Discussion Starter #4
Thanks both for the replies, im getting the impression that even if it is electric, it should still have a fluid reservoir?

Looking at those 2 pics, the earlier and the late pumps both have bottles on the top..... im confused!

I took it to garage today for diagnostics, only emmissions came up. I mentioned steering feeling odd and guy reckoned it has pas that reats to the speed, which i didnt realise, i.e. heavier at higher speeds, lighter and lower speeds.

Even if this is right, where can i put the fluid!!!! HELP!!!!
 

·
Premium Member
Joined
·
40,429 Posts
Very good F8rdy,I didn't see that one!:)

Does the speed sensitive idea sound about right?.Is it light when parking and then does it weight up when your driving it?
 

·
Premium Member
Joined
·
217 Posts
Discussion Starter #7
WELL!!!!

Its an odd one because ive never driven anything like that before to know what feels right. It does seem lighter at slow speeds but then sometimes at higher speeds it will hold firm and then when i go to move it for a lane change its heavy and then goes lighter mid-lane-change then firms up again. SO hard to describe.
 
1 - 7 of 7 Posts
Top