Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi Guys,

As the title says, I have just replaced the turbo on the above car and now the dashboard is lit up like a christmas tree!!!!! The following lights have come on and stay on:

ABS Warning Light, Handbrake light: STOP & SERV

The car has sat for about a year due to my arm being crushed at work, however these lights were not on before the Turbo went. What would be the cause for all these lights being ON. I have run diagnostic and the only code that was shown was P0670, which I beleive is for the Glow Plug control unit, which would explain why it is a little dificult to start.

I hope you guys will be able to help as I am hoping to give the car to my two kids who are both learning to drive.

Many Thanks
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
The battery is fully charged and is not the problem as I thought of this and tried a different one and the lights are the same.:confused:
 

·
Premium Member
Joined
·
334 Posts
You will have to scan the ABS for the fault you will not get them from and ECU scan
if the car has been parked up so long the abs rings may be clogged up with dirt/rust
 

·
Premium Member
Joined
·
43,291 Posts
Has the brake fluid level been checked - also check the float on its sensor hasn't stuck.

The fault code is a generic code and as it's non-Renault specific it can me misleading. It would do no harm to check the condition of the glow-plugs and check for how long the glow-plugs are getting voltage.

When a car is left unused it is not uncommon for a relay to stick so it may also be worth checking them out - sometines removing them and reseating is enough to get them going again.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
I have now replaced the Glow Plug Relay and there are no codes stored or pending in the ECU, However I still have the 4 warning light on the dash!!!

My son has beem replacing the brake discs and ball joints and at the same time we checked th condition of the ABS ring, it appeared to be OK apart from looking rusty. We have cleaned then best as we could with wire brush, We also remobed and cleaned the sensors which were covered in crud. But allas the 4 lights are still on and I am running out of ideas.:confused:

Hope someone can help:crazy:
 
1 - 6 of 6 Posts
Top