Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
I've got my new Cross-drilled vented evosport discs, new pads and calipers on my clio 1.2 today but after a 200 mile round trip, The brakes are still not very effective at low speeds.

Would there be any reason why the brakes are not very effective and generally not as good as they should be or do they just need to be worn in further?

Cheers, TJ
 

·
Premium Member
Joined
·
43,291 Posts
Hi Turbo - that's one of the penalties of having high performance brakes - they are more effective at high speeds when the temperature rises but when the brakes cool at low speeds the gripping power reduces somewhat. You can't have high performance throughout the range of speeds. That's why formula 1 cars have a warm up lap and every driver is real careful at the first bend in the race. I have seen standard cars fitted with high performance brakes fail at MOT for this very reason and if you haven't informed your insurance company of the modifications you have made to the car they may fail to pay out in the event of a claim - even if it's not your fault.:rolleyes:
Caveat Emptor
 

·
Still a Petrolhead but also like diesel
Joined
·
2,311 Posts
I've got my new Cross-drilled vented evosport discs, new pads and calipers on my clio 1.2 today but after a 200 mile round trip, The brakes are still not very effective at low speeds.

Would there be any reason why the brakes are not very effective and generally not as good as they should be or do they just need to be worn in further?

Cheers, TJ
What make and which friction material did you use? As Madnoel10 says, it maybe that the disks and pads have not come up to temperature ... you may need to change the type of friction material used to get a better balance through your operating enviroment.

Hope it helps :)
 

·
Still a Petrolhead but also like diesel
Joined
·
2,311 Posts
Were they leaking before fitting the new kit ... ? or was it the increased heat from the new disks/friction material that caused the seals to fail? :)
 
1 - 6 of 6 Posts
Top