Independent Renault Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi, I am trying to get the speedo sensor out of my friends Clio 1.6 Rxe 1999 but can't see how to do it. I read on one thread that it just pulls out but I don't want to risk damaging it. Does anyone know the correct method?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Done it

I went to 1st Call Renault breakers in Benfleet for a spare sensor and he removed one from a gearbox by removing a clip and pulling it out. However it turns out that there are two types:-

Smooth round body remove clip then pull out

Flanged body self securing - just pull out.

Went back to breakers for correct part and everything works.
 

·
Still a Petrolhead but also like diesel
Joined
·
2,311 Posts
I went to 1st Call Renault breakers in Benfleet for a spare sensor and he removed one from a gearbox by removing a clip and pulling it out. However it turns out that there are two types:-

Smooth round body remove clip then pull out

Flanged body self securing - just pull out.

Went back to breakers for correct part and everything works.

Hi the "clip" version is only applicable to some gearbox types, the biggest majority fitted to the Clio2 are the pull out type.
Make sure the ribbed seal on the electrical plug is intact, as thats where the problems usually lie, and it lets water corrode the contacts, if you can find one some later models also have a shield to help stop the water/heat damaging the sensor, its also available from Renault as a mod kit.

hope it helps:)
 
1 - 5 of 5 Posts
Top