Independent Renault Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
The dash on my Laguna II 2006 when i press the button to start the car the needles on all dials start ramendly moving and all warning lights are on.

Car starts but the display continues!!

when you start the car you get MAGNET MARRELLI on the display
 

·
Registered
Joined
·
25 Posts
Hi,
You may need to test or reset your dash display, if you search this forum you should be able to find it under 'laguna dash display test' it involves inserting your keycard a couple of times while holding down various buttons.....it will then run through a sequence of tests on your instrument display panel.
 

·
Registered
Joined
·
25 Posts
A quick test to see of your dash is working ok...

Press the button on the end of the wiper stalk to flick through the trip settings, keep it pressed. At the same time instert the key card into the reader. Let go of the wiper stalk button.

Your dash should now be in test mode, all the dial needles will cycle up and down and all the warning lights should be lit. If you now press the wiper stalk button you will flick through on the display, actual fuel consumption in litres and there will also be a fault code if any stored. If not it will be displayed like this ----. If you search the forum there is a thread saying what the fault codes mean. they look like ---h or -m--, something like that anyway! If you have 4 letters displayed start to panic lol!

If the needles of the dail aren't moving it would indicate it's dead, if they are moving your problem is more than likely something else.

To exit test mode either pull they keycard out or hit the trip reset button (everything will reset though including the fault codes)

Hope this helps.
 

·
Diamond dismember
Joined
·
326 Posts
I suspect it could be the display goes straight to test mode.
Could it be that the trip computer button on the wiper stalk is stuck, perhaps?
 
1 - 4 of 4 Posts
Top