Independent Renault Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all

I'm new to this forum so bear with me. Basically it goes like this I have a Laguna 2 iniatle 2.0 litre petrol which I have now changed the battery. While changing the battery I connected the battery poles to the wrong pole due to this I have lost all electrical power to my car.

I would be grateful if anyone could help on how to get the electrics back up and running or any suggestions to where I can take my car (already been to renault and getting no joy).

Cheers
 

·
Premium Member
Joined
·
18,909 Posts
Hi iam not sure but i would of thought that there would of been protection for the like of this like a fuse or something but this is just a guess:crazy:
 

·
Premium Member
Joined
·
14,145 Posts
Hello & Welcome to the Forums Roy100.

I'm sure someone with more technical knowledge than myself will be able to assist with your post.

Regards

Ottoman
 

·
Registered
Joined
·
12 Posts
Hi iam not sure but i would of thought that there would of been protection for the like of this like a fuse or something but this is just a guess:crazy:

You need a new UCH and a lot of luck !! You probarly fried half of the computers in the car. you are looking at at least 1000£-2000£ in repairs. Ive seen 1 person do the same thing before and it ended at 2000£ +
 

·
Registered
Joined
·
2 Posts
Discussion Starter #8
ECU failure

Hi Guys thank you all for your help and I will take these posts into consideration.

Cheers
 
1 - 9 of 9 Posts
Top