Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
hi much appreciate any ideas on a wierd problem.i bought a 2001 renault clio 1.9dti 3 months ago.its got air con so has an electric power steering pump.the power steering works fine.however 3 times with weeks between i have heard the pump (took some time to find out thats what the noise was)start up on putting key in ignition but refuse to stop when removing it.the 1st time i removed some fluid as it was over the max.then turned steering lock to lock.it stopped immediately and didnt happen again for a month.then twice in the last two weeks its happened again.disconnecting the battery for a few mins sorted it out the 1st of these but the next time (after heavy rain)its just not going away and im having to keep battery off.could it be a corroded relay sticking open?my haynes manual is useless gives no info on relays.thanks in advance
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
yeah definately a relay.reconnected battery and soon as i pulled relay board out it stopped.so that or a loose/corroded wire to the relay.what one out of the 8 or so ive no idea as they are not identified and didnt get chance to find out.so i sprayed a bit of WD on the wires and relay connecters.if it happens again i will find the culprit and open it up for a clean or replace.
when googling the problem earlier.2 people had the same problem with a mini.both went to garages which replaced the pumps at considerable expense.made me think what garage would pass up the chance of a nice little earner like that.rather than replace a relay and make nothing.you just cant trust garages.
 
1 - 6 of 6 Posts
Top