Independent Renault Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
ECU faults read.

Hi all.

After some advice on my car please.

It's a 2000 Renault megane coupe 2.0 monaco IDE

Bought it as a non runner with supposed immobilizer fault.

Checked it and immobilizer is fine. Car won't start but does try as though a cold morning.

Had it sent for a diagnostic and was told it would cost £700+ to fix???

I wasn't too impressed with the guy who diagnosed the car... proper shifty looking chap who tried to offer me £50 to take it as scrap (the car is immaculate looking with full leathers and good alloys!)...

The fault codes are below and I was wondering if anyone could shed some light as to whether this is a lost cause...

DF002 Throttle potentiometer circuit DEF (unidentified electrical fault)

DF003 Air temperature sensor circuit DEF
(unidentified electrical fault)

DF019 -Supply - 3
(injector control computer feed fault)

DF051 - can connection
(fault not listed)

DF084, DF085, DF086, DF087 - command for injector for cylinders 1, 2, 3 and 4
(all cylinders injectors short circuit to +12V)


I have been advised to check for bad earth on the ecu but am a complete imbecile with car electrics and wondered if there was any photo's as to where to use the multimeter!!

Any advice is gratefully appreciated!!
 

·
Premium Member
Joined
·
43,291 Posts
Re: ECU faults read.

Is the engine getting a spark or fuel?

Check the fuse boxes for signs of water ingress or corrosion plus the multi-plug connector to the ECU.:)

Sadly the country is full of non-runner Renaults with IDE engines due to fuel pressure problems and spares are like rocking horse doo-doo and twice as expensive.:)
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Re: ECU faults read.

Thanks for reply. Not sure about spark or fuel?

Do those fault codes mean anything to you?

Fuse box shoes no signs of water. I also checked tdc and it seems clean and almost new.

I'm going to have a look at ECU today.... where does it Earth?
 

·
Registered
Joined
·
5 Posts
Hi to all, first time user here! Have recently acquired car mentioned by richiel_7 a couple of weeks ago, still got same faults but hopefully can get to the bottom of it all! Questions i have are,

1. Have checked all suggestions so far but is there anything else i can try? have spent hours trawling this site already and think i have absorbed most of the mentioned issues associated with the megane 2.0l coupe, but not specific to my problem! I am checking all sensors and wiring but not sure what sort of reading i should be getting on the multimeter. Wiring seems fine so far!
2. If i happen to stumble on the fault and correct it, will the engine management light reset itself on its own, or does the light and fault codes need resetting with diagnostic equipment?
3.Ecu is a siemens unit part no. S110601001 D is this a sirius 32? Are the ecu earth connection still on pins 3,28,33?

Would quote richiel_7 thread but not sure how to! I think it is #5 on a search of 'megane ide'

Many thanks in advance!
 

·
Premium Member
Joined
·
40,429 Posts
Welcome to the forum.:)

I've merged your thread with the one you mention,hopefully that will avoid any confusion.I'm sure you'll have some replies in the near future.
 

·
Registered
Joined
·
5 Posts
Welcome to the forum.:)

I've merged your thread with the one you mention,hopefully that will avoid any confusion.I'm sure you'll have some replies in the near future.
thanks for merging thread lagdti, but thread isnt visible in 'unanswered, or 'new posts' can it be highlighted somehow so that ppl can see that there are further questions on thread............?
 
1 - 7 of 7 Posts
Top