Independent Renault Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello.

I have been having an issue for a while with the ESP of my Megane where I'll be driving normally and suddenly the car will loose force and the message saying "ESP off" will flash and a second later "ESP on" without me doing anything.
This mostly happens while driving on highways but it has also happened on a normal street.
It hasn't affected the driving much besides scaring me everytime it happens.

Does anyone know why this would happen?

Thank you for any help.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
My car didn't turn off at any point when the warnings appear. Again, it just looses force for a second and then everything is normal again. No warning light is on.
 

·
Premium Member
Grand Scenic 1.6 2007
Joined
·
5,605 Posts
That could be a few things. The only way to be sure is to get the codes read when it it present or hope it has stored a historical code.
One thing you could check is the security and cleanliness of the ABS sensors and their wiring. Has any work been done on wheels or brakes recently? Often they get damaged or not put back properly and that could cause the ESP to shut down.
Are any other warning lights or messages appearing?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
That could be a few things. The only way to be sure is to get the codes read when it it present or hope it has stored a historical code.
One thing you could check is the security and cleanliness of the ABS sensors and their wiring. Has any work been done on wheels or brakes recently? Often they get damaged or not put back properly and that could cause the ESP to shut down.
Are any other warning lights or messages appearing?
There was no work done since I bought the car around 2 years ago (it's from 2010 tho). I've had the tires changed a couple of times but nothing else.
There's no warning lights before, during or after. There's just the message saying ESP off and then ESP on again. These messages appear quite fast, usually i don't even have time to read the one that shows ESP off.
Again, I haven't seen or felt anything wrong with the driving asides from the 'bump' when the car looses force, I'm just curious if this could be something serious.
Thank you for the reply!
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
38,199 Posts
Can you explain will loose force
 
1 - 5 of 5 Posts
Top