Independent Renault Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi New Member

I have just bought a 95 2.0 petrol Espace, Runs great until it gets Hot, then starts to run Rough (misfire) if on the Motorway as I was last week comes to holt and back fires!!!

It sound Electrical, Has anyone else had a simila Problem or any diagnosis suggestions would be greatly appreciated!!

Thanks Darren
 

·
Premium Member
Joined
·
317 Posts
check the condition of the conections to the coolant temprature senders (there are two one for the gauge one for the ignition ) just bye the thermstat housing on the cylinder head also check all inlet pipes and hoses to your manifold check for cracks in the inlet manifold that could open with heat also heat shielding on inlet pipes whicj can cause fuel evaporation .good luck oh and ladt of all whats the air filter like ?
 

·
Premium Member
Joined
·
40,429 Posts
As Peanuts quite rightly says,the ECU temperature sensors are a definate weak spot.

Don't be tempted to buy an aftermarket sensor either,the genuine ones are expensive(about £30 from memory) but the system seems to be very sensitive to coolant temperature and the aftermarket ones can give wrong readings.

Welcome to the forum by the way.:)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Hi,
Thanks for the tips so far, I will check out these sensors and the other items Peanuts mentioned and let you know if this sorts it out
Many Thanks
 
1 - 5 of 5 Posts
Top