Independent Renault Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Hi I have a megan scenic 2001 1.4 k4j engine
The engine when cold starts up no problem then it revs up quite high for about 5 10 mins
Iv replaced the thermostat coolant temperature sensor it only does it when it's cold -1 -2 any help would be appreciated thanks
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
24,767 Posts
Depends on what you mean by quite high ?
It's normal for most engines to rev higher when cold but whether yours is normal or not, dunno?

My Q car, with a 1.6 petrol burner starts up at around 1K in summer, quickly settles to about 750rpm.
Last couple of days has been ticking over at around 1800rpm when cold....around 4c
Last winter managed over 2K when below freezing.
As the engine warms can see the tickover speed dropping.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3
It's going up to 2500 to 3500 then reving by itself between 1600 And 1000 eventually down quite happily to 750 all day
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
24,767 Posts
Poor wee beastie do seem a little lost with that.
I would suggest the coolant temp sensor may be at fault.... cannot guarantee but the cold start system all flows from that.
Relatively cheap and simple to change so could be worth the guess.
Second would be cleaning the throttle body.... could be sticking a bit if gunged in there.
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
41,918 Posts
Clean the Idle control valve,
Held on the side of the throttle body by two torx screws
 
  • Like
Reactions: Mikefranky

·
Registered
Joined
·
41 Posts
Discussion Starter #10
Depends on what you mean by quite high ?
It's normal for most engines to rev higher when cold but whether yours is normal or not, dunno?

My Q car, with a 1.6 petrol burner starts up at around 1K in summer, quickly settles to about 750rpm.
Last couple of days has been ticking over at around 1800rpm when cold....around 4c
Last winter managed over 2K when below freezing.
As the engine warms can see the tickover speed dropping.
Depends on what you mean by quite high ?
It's normal for most engines to rev higher when cold but whether yours is normal or not, dunno?

My Q car, with a 1.6 petrol burner starts up at around 1K in summer, quickly settles to about 750rpm.
Last couple of days has been ticking over at around 1800rpm when cold....around 4c
Last winter managed over 2K when below freezing.
As the engine warms can see the tickover speed dropping.
Hi I have a megan scenic 2001 1.4 k4j engine
The engine when cold starts up no problem then it revs up quite high for about 5 10 mins
Iv replaced the thermostat coolant temperature sensor it only does it when it's cold -1 -2 any help would be appreciated thanks
Hi I have a megan scenic 2001 1.4 k4j engine
The engine when cold starts up no problem then it revs up quite high for about 5 10 mins
Iv replaced the thermostat coolant temperature sensor it only does it when it's cold -1 -2 any help would be appreciated thanks
180818
180819
180820
20191201_103057.jpg
20191201_103105.jpg
20191201_105137.jpg
 

·
Registered
Joined
·
41 Posts
Discussion Starter #12
Thanks not yet the day after I posted this I put my back out after I replaced a wheel bearing
 
1 - 13 of 13 Posts
Top