Independent Renault Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello everyone
About a month ago we had in our garage a suzuki grand vitara 2006 with a f9q engine broken from oil leak.
We ve done a full engine rebuild with a new turbo and rebuilded diesel injectors.This car was with exctracted dpf and sealed egr valve along with a ecu remake program about those 2.Engine started perfect with no smoke from the exhaust and runned perfect on the road until the time that we stopped on a red traffic light on idle and when we accelerate engine reach the 0-2800 rpm easily and the stalling time starts!!! it barelly reaches 3200 rpm with the pedal down the floor.From then this is happening often but not always,and sometimes can not happen even for 100 kms distance!!!it is something that bothers the owner years now not after our remake!!!stalling problem gets fixed only if we close and re open the main switch whille driving...we cant get any dtc!!! any ideas plz???
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
39,821 Posts
So you have deleted EGR and DPF, yes


You need to diagnose it when the car dies on you
Sounds like the MAF sensor to me, but , these are not cheap..

If new turbo fitted, then Should not be overboosting, if set up correctly..
Is it a Variable Vane Geometry type turbo, or waste gate type?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
thanks a lot for your reply.
Yes they are deleted but i dont know if it is important to disconnect the egr wiring from the valve cause it is fitted on and the problem is that the "deleting" ecu program is not made by me ,the car came with it !!! i am afraid that maybe there is a missing file in the program so ia m going to remap again with a new one!!
About the maf sensor i already tried another one(used). and the same thing happened.
Turbo is VVGT so... ???
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
39,821 Posts
Chances of two Maf's giving same error on high revs pretty slim

Think your plan is the way to go at this point....

Just seems strange its not consistent ,,


VVGT, , if set up wrong could do this,
Take for a run, now boot it in 3rd gear, dont change up, until your close to limit ..
See if limp mode will occur for you by forcing ecu to react
If yes, go to the turbo actuator, Lengthen the actuator push rod,
Might take a while, but just do it one full ( 6 flats ) turn , bit of paint one one of the flats of the adjusting nut, turn it until in the same position up the thread, then use the knurled part of the actuator to take out the play pinch the nut back up, and see if it is down to overboosting..if better, or better response off accelerator you know you are going the right way with adjusting, if worse, take the nut down two full turns, and shorten the actuation of the VVG, ( Dont forget to mark the nut, you will be there forever otherwise )

Correct setting of the VVG is with a vacuum connected to the actuator, and the push rod moving a max of 3mm but not moving the VVG of the turbo, when 200 millibar is applied to the actuator
Good luck with it,
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
thank you my friend,
The turbo is already set from "turbo exelixis" in athens which is the best in greece about turbos and i have already asked about the adjustement and it is ready and checked. so thats not the problem...
i am thinking of checking the turbo vacuum pipes (one of them has a no -return valve on which i dont think it is working properly).
then i will check the oil canister tubes.
Also today i am recieving the new remap ( programmer told me that the remapping was faulty). i will remap ecu and i will let u know..
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
News of the problem !!!!
after remaping ecu we found out that DTC s WERE BLOCKED BY THE OLD PROGRAMMER!!!
From the first ride check engine went on with the safe mode!!!
DF053!!! ANY SUGGESTIONS?
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
39,821 Posts
would you know the engine code, or ECU fitted..
not got suzuki software, only on the Tech2 so will have to use Renaults, but defo need either engine code or ecu code ,,
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
39,821 Posts
Thats the engine design
3 numbers after this, need these
Still dont know what car/van you are playing with..
that will narrow it down, Year will help,
 
1 - 11 of 11 Posts
Top