Independent Renault Forums banner

1 - 18 of 18 Posts

·
Premium Member
Joined
·
1,370 Posts
Discussion Starter #1
whenever i refuel my laguna, the fuel gauge when i start up goes back to the same place as it was before hand. then continues to go down at the same rate as before til its on empty, where it stays. ive tried unplugging the fuel sender, it makes no difference, it still moves the needle back to the same place as it was when plugged in. any ideas? this has got to be a computer fault.

Laguna 2 1.9dci 2006 dynamique saloon.
 

·
Premium Member
Joined
·
1,370 Posts
Discussion Starter #3
yeah i thought so too but that doesnt make any sense because the gauge doesnt move when i unplug the sender. mind you i have no experiance of canbus electronics, and it may be its waiting for a varification signal from the sender that it's not getting. i guess im after a "this is how it works" from someone in the know.
 

·
Premium Member
Joined
·
1,370 Posts
Discussion Starter #4
having disconnected my battery for the day whilst doing a service, it seems to be behaving itself again. we'll see what happens when i next stick my customary £5 in it
 

·
Technical Supremo, Platinum Member
Joined
·
7,926 Posts
My Clio does not like small fills, I think someone at Renault as been clever but not that clever
as it does not seem to be able to get its head round small top ups if you are putting a fivers
worth in try half a tank.
 
L

·
Guest
Joined
·
0 Posts
Have you done a a test on the clocks themselves by holding the computer button in on the wiper stalk then inserting the keycard?
 

·
Premium Member
Joined
·
1,370 Posts
Discussion Starter #8
its been geting sod all put into it for more than 2 years, due to unemployment. only had a issue in the last 2 months.
 

·
Technical Supremo, Platinum Member
Joined
·
7,926 Posts
Are any earth connections to the sender OK
 
L

·
Guest
Joined
·
0 Posts
Don't know if you are aware, but when you activate self test the digital display will also tell you how many litres you have in the tank.

Couple of other readings but I'm not sure what they.
 
L

·
Guest
Joined
·
0 Posts
No idea what the other readings are?

I was told the one that fluctuates whilst revving is instant fuel consumption, but I'm sceptical.
 

·
Premium Member
Joined
·
138 Posts
this has just happened to me .... im not sure what i can do... i stuck 15 quid in there & the gauge continued to drop..??

its now sitting on the needle, the fuel light is up & the computer shows 0 miles in the tank.... which i know to be impossible, my car is UBER efficient 15 quid would get me to Scotland...lol


so.... is there a definitive answer to this issue, will buying a new sender solve the problem.??

thanks... :(
 

·
Premium Member
Joined
·
1,370 Posts
Discussion Starter #17
yup, i solved it... by accident.

i unplugged the battery whilst doing a service, and its behaved itself ever since.

turn sidelights on, unplug earth on battery, leave for a hour or so, plug back in, turn side lights off, bet it works.

make sure you have your radio code, and you'll need to reset your windows.
 

·
Registered
Joined
·
28 Posts
Hi all,

i have the same problem with my 01 Laguna (1.8 petrol). Warning light is working perfect. The readings are incorrect. When i put 15L or even 20L the needle jumps only by one or two steps from 0. I've disconnected battery and after that i still have the same problem.
Is it worth to get that sender from scrapyard? And how difficult is to replace that unit?
 
1 - 18 of 18 Posts
Top