Independent Renault Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi Can anyone help,Megane auto 2000 dti sport.
Car starts normally,but as it warms up glow plug light comes back on and injection pump starts over fuelling-engine bogs down and pours out smoke-light will flick on and off-tried renewing the water temp sensor but still the same-tried removing power from glow plugs but overfuelling still when light on dash-if light stays off car is normal and very responsive.Any help/thoughts appreciated
 

·
Technical Supremo, Platinum Member
Fiat Panda Multijet 1300 Diesel
Joined
·
5,409 Posts
EGR valve make sure you clean the shaft and the valve snaps shut on its seats,
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
EGR valve make sure you clean the shaft and the valve snaps shut on its seats,
Thanks,did that when I got home (and blanked it off-don't like diesels eating there own poo)also cleaned the MAF and temp sensor-put it all back together-started her up and took it for a run-all good,threw out a load of muck clearing itself out but then ran clean and very responsive-left it ticking over,and as soon as the temp gauge started to move,on came the glow plug light with the extra fuelling-engine hunting again and smoking -glow plug light will flick off for a few secs,sometimes if you rev it,and if light is off ,revs properly-anyone know if the glow plugs are controlled by glow plug relay along with pump fueling or is it ECU?Please help if you can,driving me nuts
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top