Independent Renault Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All,

Apologies I posted this thread under the wrong forum earlier.

Just wondering if anyone can offer any advise/assistance on a problem I'm having with the Air conditioning system on our 54 plate Grand Scenic.

When the air conditioner is switched on - light comes on but compressor does not kick in and no cold air. I have checked the fuse and its ok. This is the second time in a year that it has failed. Last time it was re-gassed and the pressure switched changed at our local Renault dealer, plus it needed a diagnostic check.

Recently the blower stopped working on settings 2&3 but has since corrected itself and started working on all settings again. Having read the forum posts, last night I went behind the Dashboard and found that the plug and the blower resistor pack had burnt slightly, so it looks as though these parts will need renewing soon.

I was just wondering if anyone knew if this blower problem would log a fault code to the ECU which would disable the Air conditioning?

I have heard that the A/C is disabled under certain fault conditions & needs to be switched back on using the Renault CLIP diagnostic tool/software. Is this correct?

If I changed out the resistor and wiring loom would the A/C fault reset itself or would I have to get Renault to do it?

I rang my local dealer to see if they could offer any technical assistance prior to me coming to them to get it sorted but they were less than useful and would not help - saying that they could only diagnose it if I paid for a diagnostic check.

As its the second time is happened quite recently, I'm reluctant to waste money at my un-helpful dealership if its something I can sort out myself.

Regards
Bren Shipley
 

·
Registered
Joined
·
14 Posts
Hi Did you get this sorted as I have a 2004 1.5 scenic and my aircon works in no1 setting but doesn't blow any air but as soon as i change to 23 or 4 the blower works but the aircon compressor doesn't. I recently changed the resistor wiring loom
 

·
Registered
Joined
·
22 Posts
Hi All,
I have checked the fuse and its ok.
AC on my 2006 Scenic (2l petrol auto) has conked out too!

Had it regassed at Renault two years ago. The compessor is not activating although 'AC' shows on the lcd display.

Is the a/c fuse in the glove box? I checked (from the manual) yesterday and all the 40A fuses seem ok. there is also a pink relay that seemed to be rather hot!

I tried checking the fuses by the battery but after removing the lid (torx bit!) it was impossible to check the fuses without removing the battery or disimantling big wires (that looked difficult to put back together!

TBH the a/c has always been rubbish since i bought the car new.

I might take her for a check to Alpinair tomorrow (near West London Renault).

Cheers
Birdface
 

·
Registered
Joined
·
22 Posts
... one more thing.

My dash mounterd CD/Radio does not eject the CDs anymore! I removed it from the dash a while ago to see if I could fix the problem (no) then refittted it.

It's possible I could have disloged an a/c wire from dash mounted switch. I have the climate control system with LCD display.
 

·
Premium Member
Joined
·
283 Posts
My compressor does not turn on as the fault with mine is that there is no pressure in the system as I have a leak.. It is designed to protect the compressor from damage. Maybe your pressure sensor was fine and it was the re-gas that got yours working again, however, if you have a small leak, the pressure will have dropped again to a level where your compressor won't cut in anymore. Just a thought...

Edit to add that the compressor won't come on if the blower is not on.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top