Independent Renault Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
The hazard lights on my ‘03 Trafic minibus have stopped working. The right- and left-turn indicators are working fine, and the relevant lights flash on and off as they should when I engage the central locking - so presumably bulbs and fuses are ok.

Could it be a problem with the hazard warning button itself, or a relay perhaps ? Any suggestions re. likely cause and how to fix it will be much appreciated. Many thanks !
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks for that, I'll give it a try - I'll be over the moon if it's something as straightforward as a dirty contact.

Can I just lever the button off with a screwdriver and just pop it back in place when I've cleaned the contacts?
 

·
Premium Member
Joined
·
112 Posts
Fingers crossed that's all it is.

To get the switch out I had to take out the centre console.

Not sure if yours would be the same though. If it is, there are 2 screws behind the ashtray, once removed the rest just pops out I think
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Top Tip - thank you!

I followed your advice and very happy to say it worked. Before getting involved in removing the fascia panel, I thought I’d try taking the easy/lazy route first, so I used the fine pipe on the WD40 nozzle and very carefully sprayed all around the button in situ, and then left it for a few minutes to seep down into the contacts to clean out any deposits or displace any moisture that was in there. Then pressed the button - and all OK!

Thanks for your tip, you’ve saved me the hassle - and cost - of taking the van into the garage for them to scratch their heads, look at the relay or replace the button (…or charge me several quid for a squirt of WD40). Cheers !!!
 
1 - 6 of 6 Posts
Top