Independent Renault Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok were to start my scenic is only reaching 4 bars on the temperature side there is heat but it's not at normal temperature should always sit on 5 bars so far I have changed the thermostat and sensor out as one unit and the problem still persists have made sure there is no air lock in the system any ideas
 

·
Premium Member
Joined
·
14,872 Posts
Sure you fitted the right thermostat?, There are some that open in the 80°C range and that will feel cold especially in today's weather over here.
Did you check it in a jug of boiling water before fitting?
Otherwise you have done the right things.
Sorry I can't shed some more light on it.
 

·
Super Moderator Technical Supremo Platinum Member
Joined
·
23,089 Posts
Could be worth getting a cheap obd reader that can check live data...coolant temp.

At the moment cannot be sure if issue is thermostat or sensor or what.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Sure you fitted the right thermostat?, There are some that open in the 80°C range and that will feel cold especially in today's weather over here.
Did you check it in a jug of boiling water before fitting?
Otherwise you have done the right things.
Sorry I can't shed some more light on it.
Yes defo the right one the place were I get my parts from tried to sell me one from a petrol with a small fitting pipe on the front that should lead to somewhere else but i told them they were wrong i got the right one after an argument with them even told them which engine my car has he finally realised his mistake and also to answer i have had the renault can clip on also says its reaching normal temperature worth and Delphi says the same but the strange thing is when I'm in standing traffic the temperature will drop down one notch and not blow really hot air so could be a blockage is my next thought or something like that i will do a check tomorrow again
 
1 - 4 of 4 Posts
Top