Independent Renault Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi there.
I own a 2002 Scenic 1.6 fidji.
Fitted towbar today but accidently shorted the indicator as I was doing the wiring :mad: Now indicators dont work, wipers dont work, drivers window dont work and worst of all car wont start. Checked all fuses but to no avail. Have read articles about UCH and I have disconnected battery in hope it will reset itself. My question is, is this likely to work and how long should I leave it disconnected for. Or is there anything else I can try to fix this. Any help much appreciated.
 

·
Premium Member
Joined
·
40,429 Posts
Glad to hear your all sorted.:)

Does your car have the poxy little fuses in it?.These are a nightmare to check,especially if you have sodding great clumsy hands like me!:eek:
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Yes thats the one. Need to have a double jointed spine to get in and babies fingers not podgy trotters like me. Anyway bit happier now might sleep tonight.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Thanks
Just for the record I havnt got an owners manual so I did not know which fuse did what. The one that had blown looked like a light with a "R" in it. I took this to be rear fog light but it musnt be. Thats why I probably never checked it :eek: . Hope this post will help others.
 

·
Premium Member
Joined
·
43,291 Posts
As all good workshop manuals say - before delving into the electrics always disconnect the battery - there must be a reason for them saying that - I used to wonder why - now I know:rofl:
 

·
Premium Member
Joined
·
1,018 Posts
As to the small fuses, you should find clipped into the fusebox a tool like a small pair of tweezers that you should use to pull the fuses out
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
Yes I used those but it was still fiddley. Does anyone know what that fuse protects (looks like a lamp with a "R" in it).
 

·
Premium Member
Joined
·
43,291 Posts
What happens when you remove the fuse (the one with the small R in it) - that may give a clue. Could it be for reversing sensors.:)
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Dont want to try anything now. Dont want to fix it when its working :rofl: But thanks for the input.
 
1 - 12 of 12 Posts
Top