Independent Renault Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I had all 4 ignition coils replaced in my 2001 Renault Megane Coupe at the beginning of April, I was away for the whole of May so did'nt use the car, now i have the same flashing light and problems due to another ignition coil going.
Does anybody know if there could be another fault that is causing the ignition coils to fail as surely you cannot have to keep replacing them every few weeks.
 

·
Premium Member
Joined
·
40,429 Posts
It's not unheard of for a new coil to be faulty,so I'd rule that out first.Also,did you have the spark plugs changed at the same time as the coils?.It is recommended that they are replaced as the resistance in them is critical to the well being of the coils.Using Genuine plugs is always a good idea.

It could also be that moisture has built up around the coils where you haven't been using it,and this can cause the same problem.
 

·
Registered
Joined
·
7 Posts
I had all 4 ignition coils replaced in my 2001 Renault Megane Coupe at the beginning of April, I was away for the whole of May so did'nt use the car, now i have the same flashing light and problems due to another ignition coil going.
Does anybody know if there could be another fault that is causing the ignition coils to fail as surely you cannot have to keep replacing them every few weeks.
Hi MPH, when he was changing mine my local Reault specialist sid he changes about 20 a week but no longer uses Sagem coils. He now uses Buna( Ithink that's how it's spelt) with good success.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
It's not unheard of for a new coil to be faulty,so I'd rule that out first.Also,did you have the spark plugs changed at the same time as the coils?.It is recommended that they are replaced as the resistance in them is critical to the well being of the coils.Using Genuine plugs is always a good idea.

It could also be that moisture has built up around the coils where you haven't been using it,and this can cause the same problem.
Cheers Lagdti,
I did not get the spark plugs changed at the same time so there could be the problem, from the feel of the car it is only one coil that has failed as i assume the more that fail the more effect it will have on performance.
I did get a reply from someone else who said their mechanic now uses Buna coils instead of Sagem and they are a lot better. Is this the case?
The first time i had this problem a few months ago i took it into a renault garage and they charged me £167 just to replace 1 coil which i thought was a rip off considering it took just a few minutes!
After that i got a mate at work who used to work in a garage to replace all 4 for £20, and i brought the coils from e-bay.
 
1 - 4 of 4 Posts
Top