Independent Renault Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hi, i have a renault megane 1.5dci expression 54 reg which ive recently bought second hand, after driving it home i noticed a fault come up saying injection fault and the stop light comes on, after about 10 seconds though this warning disappears, there was no drop in power at all so i thought nothing of it. then trying to start the engine up in the morning the engine turns over but nothing, it takes about 3 or 4 times sometimes even 6 but works eventually. I've had a look under the bonnet and noticed a bit of air in the fuel line which leads me to think the pump is faulty. when the engine is warm it'll start no problem but when its been sitting for a while it takes a while to start and comes up with the injection fault warning again. any ideas on what it maybe? and whether or not this problem is commom? oh and sometimes the injection fault comes up again over 3000 rpm but then it disappears. any answers or information would be gratefully received.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
hi thanks for your reply, after looking alot on the internet, ive found a lot of people with a similar problem, and was thinking about cleaning the egr valve might give it a try in a couple of days or see if i can get a garage to do it. would this affect the start up as well? thats what's really driving me insane. we hooked it upto an ecu reader and it came up with a code reading df056 i think its that anyway ill have to look at my notes. fingers crossed its just the EGR valve.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
hi thanks for the reply martin, i've found the proper fault code now, couldnt remember what it was before, the code that comes up is DF053 rail pressure regulation function. I try to start the car, and it doesnt start and comes up fuel injection fault, but if i bump start it, it starts straight away. I'm baffled by this :S
 

·
Registered
Joined
·
9 Posts
Hi if you clear the fault does the car start if yes but the fault comes back then it is most proberly the fuel sensor is faulty is it the orignal battery have it checked does the glow plug light and the go out.

martin
 

·
Premium Member
Joined
·
151 Posts
hi thanks for the reply martin, i've found the proper fault code now, couldnt remember what it was before, the code that comes up is DF053 rail pressure regulation function. I try to start the car, and it doesnt start and comes up fuel injection fault, but if i bump start it, it starts straight away. I'm baffled by this :S
Sounds like engine cranking speed is too low or rail pressure is too low. Getting the engine going a bit faster is just enough to get it going.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
hi thanks for all your replies, i have took the EGR valve out today and give it a good clean, put it back in, with no luck. I've now ordered a new fuel pressure regulator with sensor from the internet and hoping that its just the sensor. The car runs perfectly once going, mpg is great and what is expected. We replaced the TDC sensor a couple of weeks ago as well which hasn't done the trice, it's just a process of elimination atm. Anyone else have any ideas on what it could be if the new FPR doesn't do the trick? thank you once again. :d
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top