Independent Renault Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2011 Renault scenic 1.4 dynamique tce.
It was loosing water, fault was water leaking into cylinder 1, so had the head gasket done, head skim, timing chain, water pump etc while being done. Since then I've had the injector fault and anti-pollution fault light come on and into limp mode. The mechanic has changed the turbo cartridge as this had play and his diagnostic showed up a code for the turbo. The lights still come on intermittently, sometimes straight away sometimes after 50+ miles.
All pipes and sensors have been changed, cat checked in case of blockage. Lights still come on!
Any suggestions except selling it or crashing it! Thanks in advance.
 

·
Technical Supremo.
Scenic II, 2004, K4MW761, DPO
Joined
·
5,400 Posts
Serious - why not just make this problem that of the mechanic that did the work?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
He's tried everything, the last thing he wants to do is put a whole new turbo on it as we have already had a whole engine top end rebuild, loads of hours spend replacing sensors, checking and replacing hoses, I've spent over £1600 so far! Hence any suggestions before it goes to we want your car for peanuts . Com!
 

·
Technical Supremo.
Scenic II, 2004, K4MW761, DPO
Joined
·
5,400 Posts
If you are serious then it's time for you to start doing the mechanics job and eliminate the guessing so-and-so.

Get a Renault speaking scanner, log all engine parameters while driving and the fault happens, save the log in CSV format and post it here.

We can have a look and see the specific item tripping the ECU and take it from there.

I don't know why the friggin mechanic isn't doing this ! :mad:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
What scanner would you recommend.
What I don't get is the warning lights are injector fault and anti-pollution fault, but on his snap on diagnostic its turbo low boost pressure. code DF569
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
38,254 Posts
low boost , pipe got a hole in it going to the actuator, or pipes fitted wrong way round
 
  • Like
Reactions: LvR

·
Technical Supremo.
Scenic II, 2004, K4MW761, DPO
Joined
·
5,400 Posts
low boost , pipe got a hole in it going to the actuator, or pipes fitted wrong way round
Also - I turbo actuator diaphragm membrane perished or funky MAF ................ but surely the mechanic should be able to trace this too himself at the hand of logs :unsure:
 
1 - 7 of 7 Posts
Top