Independent Renault Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Help! My 2011 Renault Master has developed a strange issue where a few minutes after the ignition is switched off, a buzzing noise starts behind the instrument cluster and all the needles on the dials move slightly. It does this in a few second bursts for several minutes, then stops for a bit then starts up again, repeat.

It stops if you turn the ignition on but then restarts when you switch it off. Can't seem to find any way of stopping it. As it's a camper van this is really going to affect my sleep tonight ***x1f61e;

I suspect this is the reason the battery had gone flat several times recently when sitting on the drive.


Anyone any ideas please?

Thanks

Chris
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
39,761 Posts
Interior fuse box, second row up, 4th column, pull this fuse, see if it stops.
This fuse is Diagnostic socket Instrument cluster, and ALARM. could be the alarm system..
But you will need to start pulling fuses first to find out what is still powering the dash..
Take a picture of the fuse box First, find out what fuse stops your niggle
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for your reply ours2012. So.. I took the dash apart to get at the instrument cluster and the buzzing was coming from within it - presumably all the dials as all the needles were twitching at the same time. I then pulled the instrument cluster fuse as you suggested and the noise/twitching etc immediately stopped. I then put the fuse back in again and so far it hasn't restarted , so fingers crossed this may have resolved it, but any ideas what was happening? ??
 

·
Super fantastic Mod Technical Supremo Nice Guy
Joined
·
39,761 Posts
Would say a relay was not powering down for you..


But removing the fuse broke the power supply ..
 
1 - 4 of 4 Posts
Top