Independent Renault Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Laguna II Privilege June 2005 1.9TDCI.
Problem is cruise fails to pick up current vehicle speed when attempting to engage it. Display just sits there with two dashes. Sometimes it works OK. Only had it a week and no handbook so possibly I'm at fault. Any ideas?
Also anyone know if there is a Haynes manual for this model?
 

·
Premium Member
Joined
·
18,909 Posts
Hello and welcome to the forum i wish i could help but iam unable to answer your questions but iam sure someone will soon all the best Donald.
 

·
Premium Member
Joined
·
6,475 Posts
The cruise control won't engage below a certain speed (roughly 30mph, I think.) The same, for some bizarre reason, applies to the limiter.

If you're doing over 30 and the cruise doesn't set using the +, - or R buttons, then you have a fault. A 2005 model will still be under warranty, so take it to the dealer and let them worry about it. :)

There's a Haynes manual for the Lag II Phase I, though if yours is the 2005 facelifted Phase II model, then expect the cosmetic differences not to be covered in the manual.
 

·
Premium Member
Joined
·
162 Posts
I have checked my paperwork and in the handbook there is a supplement to the drivers handbook, this relates to cruise control - speed limiter, there is a reference number on the form 82 00 527 253 - 01/2005 , it may be worth contacting RCS and asking for a copy of this form , or I could scan and send to you. I do find the cruise control/speed limiter very usefull, we have a lot of road works near us with the normal cameras and also the average speed ones so I do use it a lot. Hope this helps
 

·
Registered
Joined
·
23 Posts
found with mine the drivers mat was riding up and catching the pedal hence not allowing the cruies to set as it thaught pedal was pressed needless to say bye bye:crazy: mat
 

·
Registered
Joined
·
54 Posts
Discussion Starter #8
I have since found that if I raise the clutch-pedal manually with my foot then I can set the cruise OK. Obviously either the clutch pedal restoring spring (if there is one) is weak or some little micro-switch needs adjusting.
 
1 - 8 of 8 Posts
Top