Independent Renault Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
We have had a oil and filter change, new glow plugs and we got the fault codes read.

I am not sure if these codes will mean anything as it may not be a Can Clip.

3D - Flywheel - Signal/No-Signal
5G - Needle Movement - No signal
4G - Vehicle Speed Sensor - Short Circuit
6G - Advance Solenoid - Faulty

10D - Fault Warning Light
Open circuit loss of memory
2G - Computer Supply ???

Advice for the most important things would be appreciated, not much chance of us going to a dealership....
 

·
Premium Member
Joined
·
20,098 Posts
I wouldn't panic as yet,the ECU doesn't log a date against the codes so they may have been in there for sometime.I guess the faults were cleared,so I'd give it a few weeks and then have the codes checked again.From there you can see which (if any) have come back and they can be investigated further.

If you could add your car details into the section in the UserCP function it will help you get replies to your questions too.:)
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
I wouldn't panic as yet,the ECU doesn't log a date against the codes so they may have been in there for sometime.I guess the faults were cleared,so I'd give it a few weeks and then have the codes checked again.From there you can see which (if any) have come back and they can be investigated further.

If you could add your car details into the section in the UserCP function it will help you get replies to your questions too.:)
Oh the light is still on, he reset it again before leaving, but strangely the car still goes ok, obviously it stalls sometimes when slowing down to traffic lights and so on due to the speed sensor and i should imagine the faulty solenoid is effecting performance, but it runs a lot beter after oil flush, oil change, and changing all the filters and replacement glow plugs.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
Rather than create a new thread, i decided to update this one, we visited a diesel specialist today, who upon having a listen and pulling the throttle linkage on the injector pump and giving it a bit of a thrashing, said it was 'sweet as a nut'

So i guess we can ignore all these codes, as the car goes very well since it was serviced. I have since replaced the battery but obviously light remains on, but i guess it can wait till the next oil change to get the mechanic to investigate further.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top