Independent Renault Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hi my little kangoo is playing up a bit. when cold it appears to be running on three for a brief period of time. There is not any difficultly with starting it. I was just wondering what the most likely cause is. ive changed the glow plugs so could it be the injector spray patterns? the pump? the pump timing? the adv solenoid? any info or ideas welcome.
 

·
Banned
Joined
·
1,675 Posts
I assume your engine has a conventional rotary diesel injection pump.
Pressure supplied is same for each injector so one injector will be faulty. Can be identified when engine is firing on 3 by cracking open high pressure union to each injector in turn. The one that has little or no effect on running will be the faulty one.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
yeh its got a lucas mechanical pump. its fine once its up and running and warm, only misfires on cold idle. but the mileage isnt to great im getting about 320miles to a full tank roughly. i assume the best option is to get all the injectors refurbed by a specialist. how much is it for injector refurbs now?
 

·
Banned
Joined
·
1,675 Posts
Testing of injectors is often free. Unsure about current cost for replacing injector tips. Last time I had a set of 4 done I paid about 100 pounds but that is a few years ago.
You can also lap in the seat. That is usually all they need but rarely done these days.
 
1 - 7 of 7 Posts
Top