Independent Renault Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Evening everyone!

i have a kangoo 1.9dci van 2002

very unhappy, ecu light has started coming on intermittently!

some unfriendly looking dark smoke coming out of exhaust when i pull away hard in 2nd.!!

any ideas anyone as to what this could be!!

should i start bidding on ebay for a new van!!! lol:mad:

any suggestions welcome.

thanks
 

·
Registered
Joined
·
66 Posts
im sure that the glow plug light doubles up as an injection fault warning light as there is a seprate light for engine management on mine


hope this helps
 

·
Registered
Joined
·
16 Posts
I've got a similar problem on my 1.5 DCi.
ECU & stop light flash when accelerating under load (not labouring) & the heater plug light also shows.
If I ease off the throttle they normally go out but I can also contnue to accelerate over 3K rpm and again they go out. - It's baffling me
Someone suggested cleaning the EGR valve and it's housing.
There doesn't seem to be any noticable power loss when the lights come on
 

·
Registered
Joined
·
2 Posts
hi , had this problem with my kangoo 15dci had the vas laptop plugged in saying pedel sensor malfunction , so decided to clean the electrical plug HEY PRESTO result back running fine up too now .. :toast:
 

·
Registered
Joined
·
1 Posts
I just bought a kangoo van, 1.9D and when i have waited for the glow plug light to go out i start the engine and after a second or 2 it comes back on and the van runs rough, if i switch off and then back on without waiting for the glow plug light it stays off and the van runs fine... any ideas?? thanks
 

·
Registered
Joined
·
44 Posts
Hi 88Rich - read my other posts on this. My van did the same and all auto sparks and garages gave up. It is a sensor calibration fault - not an engine fault. All they can do these days is believe what a computer says. Garbage in = garbage out is all you need to know about computers!

My post on this was titled something like "kangoo 1.9d ecu light on - second start fine."

It cost me two hours of my time and a small 0.25mm washer! Could do it in ten minutes now probably. Mountain bike front brake caliper shims do the job - pack of ten stainless for 90p!!
Good luck.
Cheers.
 

·
Registered
Joined
·
20 Posts
ive got the exact same problem on my 2002 1.9 d65 and garage after garage is stumped, my head and my wallet hurt alot. hopefully following ddelectricals fix should do it, just need a mechanic to not rape my wallet with diagnostics that dont work and to give the fix a go :mad: anyone know if the fix mentioned is for the electrical pump or the manual?
 

·
Registered
Joined
·
2 Posts
I just bought a kangoo van, 1.9D and when i have waited for the glow plug light to go out i start the engine and after a second or 2 it comes back on and the van runs rough, if i switch off and then back on without waiting for the glow plug light it stays off and the van runs fine... any ideas?? thanks
Not sure its the same problem - mine began with similar - ended up with very rough running, blue smoke and black smoke - all diagnostics showed no fault - after £ 450 at garages and about to scrap it because 'new diesel pump' advised as solution I fiddled around and disconnected Air Intake Sensor - runs perfectly now.
 

·
Registered
Joined
·
55 Posts
Hello all
If it the heater ...fuel heater light go on when car running ...keep car running and remove the relay suppying current to heater plugs.
After cleaning egr remove the electrical plug to egr and check out how motor running .
 

·
Registered
Joined
·
55 Posts
I had a ecu flashing light and unplugged the ecu cleaned with servisol and now its ok.
Also the egr after cleaning could do problem as getting false signal from ecu to open ...so disconnect the egr plug.
 

·
Registered
Joined
·
55 Posts
hi , had this problem with my kangoo 15dci had the vas laptop plugged in saying pedel sensor malfunction , so decided to clean the electrical plug HEY PRESTO result back running fine up too now .. :toast:
Hello have a2003 kangoo what kind of vas model u have and what it does please in:eek: detail .
 

·
Registered
Joined
·
2 Posts
My van 1.5 dci cut out on a busy dual carriage way just before Xmas, no warning apart from a no power problem in France a week earlier when unless the revs were over 3500 it felt like there was an obstruction under the throttle pedal , this seemed to have cleared itself so put it down to dirty fuel in France,( blame them) towed to diesel specialist and £ 1150 later,yes one thousand one hundred and fifty pounds new glow plugs and relay, all injectors out and overhauled by **** of **** at £200 each instead of £400 for new ones then two days later it started doing exactly the same as described here when pulling.lumpy on the overun as well Then cut out in the middle of Epsom last night, now waiting for diesel specialist to get back from Spain to sort it out,( bet he had a good holiday! ) How can I be sure he has done all the work that is on the bill and also why after all this work is it now doing this?
 

·
Registered
Joined
·
2 Posts
Just a follow up, after spending £1150 on injectors, glow plugs etc and it conking out again the final total was £2700 , it needed new fuel pump which was breaking up inside and leaving 2 micron type paste in fuel which got in tank that then got back into fuel tank and back into all 4 injectors rendering them U/S Garage only charged me for 2 as a gesture of good will however, so 4 new injectors ,cam belt , in line magnetic fuel filter fitted, tank dropped and cleaned £50 diesel thrown away as contaminated . So I now have a 54 plate van that has cost £2700 to get repaired. Never had a Renault before and I really wish it had stayed that way. Every one tells me the Delphi system is rubbish and I have to agree, stick with Bosch next time, really ****ed off
 
1 - 16 of 16 Posts
Top