Independent Renault Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Trying to put an original stereo I'm my 07 kangoo. Got display but looks like I need a wire to plug into it.. does anyone know where I can get one from please
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
8,506 Posts
Sorry for being old and easily confused

I take it, the car had an aftermarket stereo in and you are switching it back to the original Renault stereo?

If you have got the correct head unit, then all the cables should fit, unless the harnass was sliced into, to get the aftermarket stereo to work

P.S. Welcome to the Forums
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for the welcome..
The head unit is coming Wednesday and all wiring seems to be okay .it's under the display that I think a wire is missing..I'll try add a picture. Is there supposed to be a wire from the grey plug to the black plug..
186199
16000655765895414247742224944078.jpg
186200
16000655765895414247742224944078.jpg
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
8,506 Posts
Unfortnatley from the pictures I dont know, I take it that the display functions properly without the cable there? is that the only connector that feeds the display unit? it maybe a connector for the additional GPS display that your modle may not have but was an available option
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
The display doesn't work at the moment..I can't seem to find how to get it working..I'm guessing it need the lead into it but not sure where from...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I've been told that there is a lead that plugs into back of radio, and that goes into the display to power the display.. just need to know where to get one from...
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
8,506 Posts
that is part of the loom and as long as the person who fitted the aftermarket stereo, did not savage the Loom in any way, when you pull the aftermarket stereo out all the connectors should be there, if the person has cut and sliced their way through the loom, then you are on a very sticky wicket as you are going to have to rebuild the whole head unit loom
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
8,506 Posts
does it look like there are a lot of cut and repaired cables in the back, as they may have hacked the old loom to fit the new stereo connectors in, if so you will need either new stereo loom to refit the old stereo or someone with a lot of in car electronics knowledge to rebuild your loom to factory specs
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Have looked and there is no cut cables at all.. have been told that it's on wire that connects the original radio to the display
 

·
Technical Supremo, Platinum, I let the Dogs out
Joined
·
8,506 Posts
ok, I would have assumed that the connectors would have been still part of the loom that is wrapped in black ribbon at the back of the stereo, the previous guy may have removed it, I am unsure if you can get just that part of the loom, maybe from a scrappies where you can remove it from that loom
 
1 - 11 of 11 Posts
Top